Announcement

Collapse
No announcement yet.

UE4 - Vsync and Framerate limit cause screen stutter and freezing movement. why?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4 - Vsync and Framerate limit cause screen stutter and freezing movement. why?

    Hi, I´m testing Framerate limit to 60 "set frame rate limit" node, and also Vsync in my project and now while moving through the scene, it causes a weird stuttering freezing camera movement or screen stuttering, it is very annoying because every 1 or 2 seconds it makes this small and slightly freeze, if I set the Framerate back to unlimited "0" and disable Vsync, it restores an smooth, linear and clean movement again, what can I do, is this constant screen freezing normal? my problem is that if I don't incorporate them, Unreal makes my project to run at 300fps LOL.... and some PC can handle high Framerate, over 60, but not everybody can, so, framerate limit and Vsync options are a must, but now i get this stutter that I honestly don't know what to do.

    Also It cant be fixed in-game, I have to uncheck Vsync, set frame rate to 0, unlimited, save - close, restart, and then the weird freezing screen is gone.

    Please help
    Last edited by DraxFX; 11-19-2020, 08:44 PM.

    #2
    DraxFX Hi! I was wondering if you already tried playing around with the Smooth Frame Rate settings?

    Comment


      #3
      Do you mean the smooth frame rate I belive is inside the Project Settings?

      Do you think I should check "smooth frame rate"? and decide a min and max? what range do you recommend? because actually I disabled this option some time ago, because I followed a video tutorial, that in order to use Framerate limit and Vsync togueter recommended to to disable smooth frame rate, also by default, UE has as min 22 and max 62.

      Comment

      Working...
      X