Announcement

Collapse
No announcement yet.

"Event Begin Play" Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Event Begin Play" Question

    Just a quick question, obviously you cannot have more than one event begin play module in your level blueprint (at least that has been made apparent). I have widget blueprint set up with an event begin play module installed to it and I need to install a pressure plate to tell a bridge to rotate. The issue I have is that I need an event begin play module to set the location of my pressure plate so that it knows where it started and where it will be at when the animation is finished. Is there an alternative to this, I tried an actor class blueprint but I could not reference either the trigger box or the plate itself at all.

    #2
    So your question is how you can connect an event begin play node to several actions? When yes, then take a look at the "sequence" node

    When you want to do it in an actor bp, you just have to add your mesh in the component tab + a box/sphere/... After that in the properties of the box/sphere/ you have to go to event - now add a "on component begin overlap". After that it will open the event graph and in there you can add your actions (havent tried it out with a widget bp)
    Last edited by fighter5347; 09-26-2014, 06:41 PM.

    Comment


      #3
      Originally posted by fighter5347 View Post
      So your question is how you can connect an event begin play node to several actions? When yes, then take a look at the "sequence" node

      When you want to do it in an actor bp, you just have to add your mesh in the component tab + a box/sphere/... After that in the properties of the box/sphere/ you have to go to event - now add a "on component begin overlap". After that it will open the event graph and in there you can add your actions
      so i am doing the wrong thing here by placing my blueprint in the level blueprint. Here is a picture, let me know if you see any flaws. Mesh is set to movable and the trigger box only response to pawn. Also the sequencer is split between the blueprint I set up for my hud (widget blueprint) and the blueprint for my pressure plate.

      Edit: This is just to make sure that I am getting the right message


      Last edited by XLCRHItmanEQ; 09-26-2014, 06:44 PM.

      Comment


        #4
        I lied to you, I wasn't noticing it move because I had the timeline set to trigger in too long of a time frame, but still not responding in a way that I would like.
        Last edited by XLCRHItmanEQ; 09-26-2014, 06:55 PM.

        Comment


          #5
          Make a blueprint for your pressure plate and use an event begin play in it's event graph. See the event begin play inside an individual BP triggers when that actor is spawned, same with the construction script for that BP, then if you drag and drop your pressure plate BP into the level it will work independently of the level BP.

          Comment


            #6
            Originally posted by nabiul View Post
            Make a blueprint for your pressure plate and use an event begin play in it's event graph. See the event begin play inside an individual BP triggers when that actor is spawned, same with the construction script for that BP, then if you drag and drop your pressure plate BP into the level it will work independently of the level BP.
            This would be done in a class bp? Just to be sure, I was learning a lot about bp's and then I had to step away to level creation and I lost a bit of knowledge in the process.

            Edit: See I had tried to create a class blueprint-->Actor, I tried to bring in a reference for location into the blueprint and it would not let me reference the plate. I also tried creating a "blueprint using" by right clicking in the content browser and i really could not get it to do what I want, the only reference to the object I could get was a static mesh reference even thought the object is set to be movable. I got the pressure plate to work, go up and down using a simple trigger box, but the plate bp was done directly in the level bp. but I am having trouble getting it to effect the bridge at all. Tried add local rotation and it was a little crazy at that point.
            Last edited by XLCRHItmanEQ; 09-29-2014, 03:11 PM.

            Comment


              #7
              here is a picture of what I have so far, ran into a bit of an issue trying to set references to the mesh. I couldn't assign target in set and get actor location. is this the problem or am I just messing around with a brush that just does not accept this in a class blueprint.



              and here is a picture of the component section so you can see what I am working on.



              also I can not adjust the collision settings within the compnonent editor for the box i installed.
              Last edited by XLCRHItmanEQ; 09-29-2014, 05:23 PM.

              Comment

              Working...
              X