Announcement

Collapse
No announcement yet.

Blueprint collision,i need help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blueprint collision,i need help!

    Hello guys,after following the video tutorial of: How to make a road with blueprints function,i obtained my "splitcomponent road" but there is a problem,when i collide the road,i went into this...
    Well, i'm using in my splitcomponent the basic static_mesh "floor_400x400" so the collision must be already on right?
    Where i'm wrong? :/
    This is the screenshoots for what happening:
    If you need something else just tell me,thank you.
    Click image for larger version

Name:	splinecollision1.jpg
Views:	1
Size:	526.4 KB
ID:	1138801

    Click image for larger version

Name:	splinecollision2.jpg
Views:	1
Size:	397.4 KB
ID:	1138802

    #2
    They are a option to show the coliders. You can check those first. Find it in the show label in the view.

    Comment


      #3
      Can you make me a screenshoot with the part of these options highlighted?

      Comment


        #4
        Really?

        Click image for larger version

Name:	Captura.PNG
Views:	1
Size:	361.1 KB
ID:	1057071

        Comment


          #5
          ok i will try when i go home,thank you,i'll let you know!

          Comment


            #6
            I still got the problem,when i walk on my road,i'll pass trought and i dunno how can add collision to my splinefunction!

            Comment


              #7
              up
              No one can help me about this splinemesh collision? :/

              Comment


                #8
                The spline mesh component's default behavior when added to a blueprint is No collision. Open your blueprint and go to the components tab. Select your spline mesh component and scroll through its properties to the collision settings. Set it to BlockAll or anything else you require.

                Comment


                  #9
                  I've already tried to go in component settings and look at the splinemesh settings,but i didn't found anything about collision options!
                  If you can,can you make me a screenshoot about where i can find this?
                  Thank you!

                  Comment


                    #10
                    Originally posted by TheHouseOfTheGames View Post
                    I've already tried to go in component settings and look at the splinemesh settings,but i didn't found anything about collision options!
                    If you can,can you make me a screenshoot about where i can find this?
                    Thank you!


                    Perhaps a workaround , check if you got a Sphere componenet and set that to blockAll
                    Last edited by Archiechoke; 09-29-2014, 07:38 AM.

                    Comment


                      #11
                      ok i'll check tonight when i come back come!

                      Comment


                        #12
                        Originally posted by TheHouseOfTheGames View Post
                        ok i'll check tonight when i come back come!
                        Too much game of thrones . :P

                        Comment


                          #13
                          This is what you should look for.

                          Click image for larger version

Name:	splinemesh-collision.png
Views:	1
Size:	181.5 KB
ID:	1057215

                          And I just realized you might be creating the spline meshes in Blueprints.. In that case try these nodes.

                          Click image for larger version

Name:	dynamic spline mesh collisions.png
Views:	1
Size:	42.2 KB
ID:	1057218
                          Last edited by james0x0A; 09-29-2014, 12:00 PM.

                          Comment


                            #14
                            Thank very nice i solved the problem adding the Set collision enbabled!

                            Comment

                            Working...
                            X