Announcement

Collapse
No announcement yet.

[Solved] Can't map buttons on Oculus Quest

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Solved] Can't map buttons on Oculus Quest

    I am trying to map the input of the Y button on the left controller for the Oculus rift. According to the instructions here https://developer.oculus.com/documen.../?locale=en_US

    It should be MotionController (L) FaceButton2. That doesn't exist. If I do facebutton these are the choices I have only have gamepad events face button top, bottom, left and right. What do I need to use to map this button? I am using UE4.23.4 and Oculus VR 1.41.0

    Thanks.
    Last edited by Kobaltic; 03-27-2020, 01:35 PM.

    #2
    I added a screen shot of what I have for Oculus

    Click image for larger version

Name:	oculusUE4.jpg
Views:	18
Size:	26.3 KB
ID:	1737830

    Comment


      #3
      have you tried to see if back, enter or home work for that button?

      Comment


        #4
        So I figured this out. I had to go to project settings and input. I created a new Action Mappings called ButtonY. I then tied it to the Oculus Touch(L) Y press. I then used the input->action event -> ButtonY. This is actually really good as I can now map other buttons to the same mapping.

        Comment

        Working...
        X