Announcement

Collapse
No announcement yet.

Multiple physicle materials with Layer Blend

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Multiple physicle materials with Layer Blend

    Hi,
    I am having a problem determining, what material my vehicle is on.
    My goal is to spawn according particles under the vehicle.

    I followed some tutorials but I seem to have overlooked something. I have no idea, what that might be and beg for your help.

    The problem is: Though I followed the instructions step by step, my screen looks as follows:
    Click image for larger version

Name:	serpentproblem_1_screen.jpg
Views:	275
Size:	182.5 KB
ID:	1720902
    Marked to the left is the surface type, which is always default. It should be Lehm (Clay in German, sorry).
    The marked white box is the hit from the linetrace. It is under the landscape, because the landscape has some displacement.

    What has happened so far:
    To give you an idea, what I may have missed or done wrong, this is what happened.

    Click image for larger version

Name:	serpentproblem_2_project.jpg
Views:	121
Size:	131.1 KB
ID:	1720904
    First I entered all the surface types I might need under the project settings.

    Click image for larger version

Name:	serpentproblem_3_phys_mat.jpg
Views:	127
Size:	69.4 KB
ID:	1720909
    Then I made one physical materials for each surface type. Marked is the setting for the surface type, as that seems to be the relevant information.
    I didn't change the physics settings at all.

    Click image for larger version

Name:	serpentproblem_4_select_layer_info.jpg
Views:	121
Size:	298.2 KB
ID:	1720907
    Then under Landscape > Paint I selected the Layer Info Assets and opened them.

    Click image for larger version

Name:	serpentproblem_5_layer_info.jpg
Views:	122
Size:	52.1 KB
ID:	1720906
    For each Layer Info Asset I selected the according physical material, that has the surface type in it.

    Click image for larger version

Name:	serpentproblem_6_blueprint.jpg
Views:	123
Size:	259.5 KB
ID:	1720911
    And finally in the blueprint of the vehicle Actor I generated the line trace.
    The Hit should have delivered the surface type, which doesn't work.

    I thought to have understood, what is happening here. But there is obviously a gap, that I can't close by myself.
    Just for testing, I then set the physical material of the landscape material to ice. That didn't change anything either. So I seem to have missed something basic.
    Click image for larger version

Name:	serpentproblem_7_mat.jpg
Views:	123
Size:	259.7 KB
ID:	1720908

    Thank you for reading so far and I am looking forward to some hints and wild guesses

    Sincerly
    Christian

    Attached Files

    #2
    Update:
    I made some more testing and the problem is located in the Layer Blend.
    Placing some Objects and driving on them return the expected surface type.

    Any help is appreciated, thank you.
    Regards
    Christian

    Comment


      #3
      Update:
      This morning I found this: https://forums.unrealengine.com/deve...return-default
      It says (01-29-2020), the issue has been fixed in the new Hotfix.
      I guess, it means 4.24.2, right?

      Regards
      Christian

      Comment

      Working...
      X