Announcement

Collapse
No announcement yet.

How can I get the camera to blend?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How can I get the camera to blend?

    Using Set Active I can switch cameras, but that doesn't blend it smoothly. Do I need to uncheck auto-activate on the follow camera? If I do then, the camera goes wonky.
    Attached Files

    #2
    Perhaps set a Blend Exponent value?
    [LEGENDS of EPICATwitter Discord]

    Comment


      #3
      Originally posted by unit23 View Post
      Perhaps set a Blend Exponent value?
      I think I tried that before and blend never worked (Camera Components in same actor).
      But if it doesn't, what will work is spawn or use a spare level-based 'Camera Actor' etc.
      Then the blend will work correctly, (you'll need to attach the camera to the target Pawn).
      Note if you're expecting old Spring Arm behavior, you'll have to still account for that too.

      Comment


        #4
        Thanks for your answers, I'll try that this afternoon.

        Comment


          #5
          The basic problem you're running into is that the "Set View Target with Blend" node does not work on component level, but on actor level. You basically tell Unreal to "Get Owner of FPCamera" which is the player (or the pawn you're working here), and "Get Owner of Follow Camera", which is also the player. In both cases, Unreal will switch focus from Player to Player. You'll see it will work if you switch from e.g. your player to an NPC or some other with a camera attached.

          An option would be to use the "Set Active" method you already mentioned, and write blueprint (or C++) functionality to interpolate the position of the other camera until it is at the same point as your other camera, then deactivate the component and reset to its old position.

          Hope this helps.

          Comment

          Working...
          X