Announcement

Collapse
No announcement yet.

How to stop pawn animation after possessing another?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to stop pawn animation after possessing another?

    I have created a moving platform as a pawn. When character overlaps invisible collision sphere the character will be unpossessed, teleported to a certain point and inherited pawn rotation. The problem is that Animation blueprint keeps running last animation state, in my case walking\running when the character should stay still. I found that for some project option "Run Physics with No Controller" helps but in my case physics isn't suitable.

    #2
    Originally posted by HenryVIII View Post
    The problem is that Animation blueprint keeps running last animation state..
    Add another animbp state, set a bool directly, or use an interface to set the bool, on the bool trigger that new state with animation of your choice. You could also hide the mesh of the character currently not possessed (if this is an option).
    Reallusion Unreal Engine Community Manager / LEGENDS of EPICA [Twitter] [Facebook] [YouTube] [Vimeo]

    Comment


      #3
      Add another animbp state
      As I understood this state should be set before un possessing? Looks like animbp losing updating tick after.

      Comment

      Working...
      X