Announcement

Collapse
No announcement yet.

4.24 - phys mat issues?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.24 - phys mat issues?

    Hi All, Is anyone else having bad results with physical materials on landscape?

    I literally just re-set all of them up, since my project didn't want to just migrate and I had to re-build on a new blank.

    From what i'm seeing Out Hit Phys Mat always returns a blank display name, or a False for "is valid".

    Now, chances are I missed something while setting stuff up. however, curious to know (since I can't debug till tomorrow anyway) if anyone else experienced similar issues.


    NB: the landscape (which had work done to it) isn't working, an override on a box with a phys mat works just fine.
    Last edited by MostHost LA; 12-11-2019, 05:53 AM.

    #2
    Bump. Dealing with this today. I still haven't found an error or mistake in the way I have set it up, leading me to believe it is a bug...

    Not a bug I guess. works fine in a properly converted new project. not at all in the imported one... -__-
    Last edited by MostHost LA; 12-11-2019, 03:50 PM.

    Comment


      #3
      Ok, one more update. It seems like an engine bug. It works just fine in an old converted project, but I can't get anything to work on a new project. the trace result is always False fro the Hit Phys Mat when touching the landscape.
      Both using layers and not using layers.

      Comment


        #4
        I'm having this bug too.

        Comment


          #5
          It's been reported and they have told me it's fixed on the internal - however they do not know if it will make the patch.

          Comment


            #6
            I have encountered this bug on my landscape as well. Ver. 4.24.0
            Hoping it is fixed after holiday break.

            Comment


              #7
              Same problem here.
              Spended al lot of time to figure out what's wrong with my project upgrade to 4.24. It results in reporting as engine bug. Hopefully they fix this issue soon.

              Comment


                #8
                Me too, 4.23 and older version is ok. But in 4.24, hit result can not get the correct surface type and physical material from landscape. Hope fixed next version````

                Comment


                  #9
                  Seeing same issue in my project. Is there a bugtracker ticket I can watch?

                  Comment


                    #10
                    According to support it was fixed immediately but couldn't make the pre-holiday patch. So we have to wait until they release the latest (or you could build the latest dev branch).

                    Comment


                      #11
                      Has this been fixed? I'm still encountering the bug. Line trace doesn't return physical material for Landscapes. I'm using 4.24.1 source build from GitHub
                      Grand Guilds | Twitter | Facebook


                      AI Behavior Toolkit - UE4 Marketplace

                      Comment


                        #12
                        Apparently not.
                        my last communication with support said that this issue presented itself when upgrading to .24

                        Apparently if you upgrade to .24.1 the issue won't be there.

                        I haven't had time to test this out yet.

                        The pipeline would be to grab an old project - which you hopefully still have - upgrade to the new engine, and assuming it works, move the last month of work over. Manually.

                        Here is the tracker that support gave me.
                        don't ask me why this is it. I still think he gave me the wrong link.
                        https://issues.unrealengine.com/issue/UE-85928

                        ps: please sign on and vote it, so that we get a proper fix.
                        additionally you could file a new bug report for line traces exclusively...

                        Comment


                          #13
                          I am having the exact same issue.

                          I switched from 4.22 to 4.24 and I didn't noticed the issue at first, but now duuh I will have to downgrade with all the hassles it implies...

                          Comment


                            #14
                            Landscapes not returning physical materials has been fixed in the 4.24 branch but is not in the release branch yet. I guess we're getting another hotfix at some point.

                            (This worked for me in 4.23)

                            https://github.com/EpicGames/UnrealE...ision.cpp#L603

                            Comment


                              #15
                              As of the latest release - 4.24.2, I can confirm this is corrected. (finally).

                              Comment

                              Working...
                              X