Announcement

Collapse
No announcement yet.

Jerky rotations with rotation component when it should be smooth

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Jerky rotations with rotation component when it should be smooth

    Hi, I have pawn I am spawning into a menu scene, the pawn has a rotating movement component added with a rotation rate of Z = 6. The camera is on a spring arm. The idea is the menu level scene loads, the pawn slowly pans the camera around the Z-axis while the menu widget is on the screen. This works as I expected it would. But the rotation has periodic pauses, there are freezes every half-second or so for maybe 2 or 3 frames at 60fps

    I tried loading different scenes, the complexity of the scene seems to have an effect on the length of the pause, but even if I use the standard Siple VR level as an example it has the same jerky feel.

    This happens in the editor and if I package the project and run it by itself. My PC is reasonably capable thread ripper with 32gb ram and a 2080ti, I am running it at 4k but this doesn't seem complex enough to make the pc struggle. The GPU profiler says the scene takes 2.49ms with the slate system taking an additional 1.27ms, to my understanding that should be able to render 265fps before it starts to lag but it is struggling at 60fps

    So I think it is how I have set up the scene with the rotation component, but I don't know what to look at to fix it.

    #2
    Here is a video to see the micro pauses https://youtu.be/dR7QW4MNBA4

    Comment


      #3
      Originally posted by Bolad Daurian View Post
      Here is a video to see the micro pauses https://youtu.be/dR7QW4MNBA4
      Change your engine scalability to Medium under settings and test it.

      Comment


        #4
        Originally posted by Rev0verDrive View Post

        Change your engine scalability to Medium under settings and test it.
        Yes it does.

        Comment


          #5
          Originally posted by Bolad Daurian View Post

          Yes it does.
          Scaling down should increase performance, thus frames should be smooth. If the camera panning is smooth with no jitter, then it's an indication that you lack the hardware resources to process it at higher detail.

          What are your system specs?

          Comment


            #6
            Originally posted by Rev0verDrive View Post

            Scaling down should increase performance, thus frames should be smooth. If the camera panning is smooth with no jitter, then it's an indication that you lack the hardware resources to process it at higher detail.

            What are your system specs?
            That's why I am confused about it, Nvidia 2080ti, threadripper, 32gb ram, nvme drives etc... it's running at 60fps, and just doing these rhythmic micro pauses, I think it is the rotation component, pausing, but lack the knowledge to prove one way or the other.

            Comment


              #7
              Originally posted by Bolad Daurian View Post

              That's why I am confused about it, Nvidia 2080ti, threadripper, 32gb ram, nvme drives etc... it's running at 60fps, and just doing these rhythmic micro pauses, I think it is the rotation component, pausing, but lack the knowledge to prove one way or the other.
              Occlusion test .... Create a decent sized hollow cylinder with geometry tool. Place it around your camera. Ensure that it occludes everything in FoV. Run a test.

              If you're still getting dips, then you can look at tick dependencies. Rotating movement component is tick bound.

              Adjust tickrate in console ... t.maxFPS. Test at 30 and see if that reduces or eliminates the stutter. Lower tick increases tick interval .... more time to do what needs to be done.
              Last edited by Rev0verDrive; 12-06-2019, 09:50 PM.

              Comment


                #8
                Originally posted by Rev0verDrive View Post

                Occlusion test .... Create a decent sized hollow cylinder with geometry tool. Place it around your camera. Ensure that it occludes everything in FoV. Run a test.

                If you're still getting dips, then you can look at tick dependencies. Rotating movement component is tick bound.

                Adjust tickrate in console ... t.maxFPS. Test at 30 and see if that reduces or eliminates the stutter. Lower tick increases tick interval .... more time to do what needs to be done.
                Thanks, I did that and it is still happening so now I am looking for a tick-based cause. Thanks for your help

                Comment

                Working...
                X