Announcement

Collapse
No announcement yet.

Aiming problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Aiming problems

    Hi,

    so I'm having a couple of issues implementing the aiming.

    a)
    I can't seem to to make the projectile shoot towards the crosshair.
    (In the picture right below I tried out different ways to aim...but I'm probably to dumb to figure it out...-.-)
    Doing the Linetrace this way:
    Start: CameraWorldPosition
    End: CameraWorldPosition + CameraForwardVector * Range
    makes the projectile perfectly go to the crosshair. But then, problem b) occurs.


    Click image for larger version  Name:	trytoaim.PNG Views:	0 Size:	160.5 KB ID:	1690302
    Spawning the projectile:
    Click image for larger version  Name:	spawningprojectile.PNG Views:	55 Size:	144.2 KB ID:	1690308

    b)
    When rotating around the player, at certain angles I shoot the player, like seen in
    the picture (the first of health bar). In this case it looks obvious (as the aiming offset animation
    is not working correctly), but this also happens when the camera is
    right behind the character. And it also doesn't matter whether I'm shooting from the TP
    oder FP perspective. The projectile still often goes to the character.

    Click image for larger version  Name:	shootfail.PNG Views:	0 Size:	244.5 KB ID:	1690303

    c)
    As you can also see the aim offset messes with the body rotation. I don't know how to fix that.

    d)
    The other very annoying thing is, that I get tons of warning stating that the slot node
    "upper body" already exists.

    Click image for larger version  Name:	slotnodewarning.PNG Views:	0 Size:	98.5 KB ID:	1690304

    The animgraph looks like this atm:
    Click image for larger version  Name:	animbp.PNG Views:	0 Size:	83.8 KB ID:	1690305

    There are even more problems with aiming, but I thought it might be better to list a few for now....hope the rest will get fixed automatically.
    Any help would be highly appreciated. Let me know if you need more screenshots.
    Last edited by User345546056; 11-25-2019, 11:35 AM.
Working...
X