Announcement

Collapse
No announcement yet.

ASAP: UE4 takes a long time to load HRees textures when it starts for the first time, why?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ASAP: UE4 takes a long time to load HRees textures when it starts for the first time, why?

    Hi, i have this problem since UE 4.19, but now it´s kind of worst in UE4.24, as i click play (PIE) for the first time, after launch Unreal Engine, everything looks horrendus, all textures without exception load in low rees and frame rate is as low as 1 to 2fps; to kind of fix this…. every time i load UE i click play and close that window several times, once i clicked it 4 times, textures finally load looking perfect and fps is restored, other times if i play like this, it takes about 5 to 10 minutes until textures suddenly change to high rees, why this happens?

    Is this also going to happen to every player after package? What can i do?
    Last edited by RoccoFX; 11-10-2019, 05:43 PM.

    #2
    this is texture streaming, most likely you have to many textures for the streaming pool size you have set (default is like 1Gb) r.Streaming.PoolSize then a number after will alter the pool to that size. for instance on my 980Ti i have it set to 5500 because i have 6GB video card ram.
    also make sure you use performance profiling to find any areas affecting slow loading/bottlenecks

    ttps://docs.unrealengine.com/en-US/Engine/Performance/index.html
    CEO of Prydetech

    https://www.artstation.com/ixicalibur

    Originally posted by ixicalibur
    Here you go, this is a link to every tutorial you could ever need plus instructions to access all the collective knowledge of mankind: [Super massive awesome link that every amazing game developer uses to instantly learn to be super awesome at making stuff]

    Comment


      #3
      Thanks,

      i have set it to 4000, my pc its kind of old, so, you think if i increase it to 5500 for example, i Will have more issues like this…. BUT, a person with a recent and cool pc, wont? in this case, i shouldn´t worry right?

      I had to increae my pool size… because it was over, about a month since i started my Project LOL... but i do understand the performance issues ater using too many 4ktextures.
      Last edited by RoccoFX; 11-13-2019, 05:19 AM.

      Comment

      Working...
      X