Announcement

Collapse
No announcement yet.

UMG slider laggy / unresponsive

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UMG slider laggy / unresponsive

    Hi everyone,

    I'm currently adding the interface to my application. In UMG I added two slider, changed the textures and mapped the ranges as I need them. The functionality (setting my game parameters) works fine, though interactionwise I have huge problems: Problemvideo

    As you can see the sliders are really laggy and pretty unresponsive and I can't find any way to fix it.

    The lag is slightly reduced when I use the basic slider without any custom textures but still not great (And it's no option to use the basic slider anyway) The same problem occurs on a new project too, on different computers too.

    I also tested the sliders on the target device (Computer with Touchscreen) and the sliders is unresponsive there too (I would say even more so)

    Does anyone have an idea how to improve the slider performance? I thought about building a custom slider yesterday. But even moving an image along the cursor seems super laggy. (The image pulls behind the cursor)

    Cheers and thanks for your help! Daniel

    #2
    The solution to the problem (or what caused the problem):

    I created the slider with a value range of 0 - 100 and step size of 1 to output nice values in the text field.
    As I wanted the values to be rounded when interaction with the mouse/touch I checked: Mouse Uses Step.
    This of course, set the values correctly, but added lag to the dragging.
    So deactivating it and rounding the values for the textfield in the function solves this.

    Comment

    Working...
    X