Announcement

Collapse
No announcement yet.

Damage Feedback Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Damage Feedback Problem

    Hello, guys!

    I try to reconstruct this shooter tutorial from Andrzej Koloska works fine so far, but in the section where he made the damage feedback. first i have a normal enemy the TPS, everything works good, only i have change another enemy like great spider from free assets on the marketplace and did the same reconstruct at the new enemy, but now from damage feedback floating text,
    still getting zeros nothing calculating.
    Don't know what i am did wrong, thought i miss something.
    Here some pictures and a demonstrating video:
    Hope anyone can help me out.



    #2
    Hi Clatu, I didn't get a chance to go through all the screenshots, but from a quick glance, I believe the third screenshot involving the ModifyHealth function could have a potential problem. When you're calling the Subtract node, try plugging the Current Health to the top input and Health to Modify to the bottom one. If not, you might always end up getting either 0.0 (if True) or a negative value (if False) for the health.
    Unreal Possibilities
    Wave Spawning System | Tower Defense Starter Kit | Line of Sight Visualization

    Comment


      #3
      Originally posted by Stormrage256 View Post
      Hi Clatu, I didn't get a chance to go through all the screenshots, but from a quick glance, I believe the third screenshot involving the ModifyHealth function could have a potential problem. When you're calling the Subtract node, try plugging the Current Health to the top input and Health to Modify to the bottom one. If not, you might always end up getting either 0.0 (if True) or a negative value (if False) for the health.
      @Stormrage256. Thank you for the fast reply, have try that was good tip, but still getting the same effect when i change this, have debugging this all i get a fireimpuls of event graph and functions i think everything is not calculating.

      Comment


        #4
        Ok guys, i solved my problem, thanks again to Stormrage256, that what you said was also a issue what i make wrong with the connecting.
        The problem was in my calculate shoot information function have guess the vector location from the break hit results node to the find look at rotation node that was also a issue.
        After that i guess some variables get some datas, that's all i have to do, but this forum let your brain working you find out by your self good forum

        Comment

        Working...
        X