Announcement

Collapse
No announcement yet.

SetActorTransform node won't change the location of actors that simulate physics (???)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    SetActorTransform node won't change the location of actors that simulate physics (???)

    So I am basically trying to change the transform and the velocity of a rolling ball. The ball is supposed to teleport away as soon as it touches a specific overlap/trigger box but it doesn't work as expected. The velocity of the ball changes but the transform of the ball stays the same. Since it's a rolling ball, it is of course simulating physics (important to note; the velocity change is executed AFTER the "SetActorTransform" node, so I know for a fact that the blueprint graph actually fully executes). Could the fact that it's simulating physics have anything to do with this? I read in some old forum posts, where people used older versions of UE4, that the "SetActorTransform/Location/Rotation" nodes had no effect on actors that simulated physics. Is that still the case?

    I recorded a video showcasing the issue: https://www.youtube.com/watch?v=DRQsWLCnnaM (the white wall has NO COLLISION, so the ball isn't bouncing back due to collision. I checked. It's just not shown in the video)

    So my questions are basically:
    1. What the hell is actually causing this?
    2. What's a good way to fix it?

    #2
    STRANGE. I know that objects stop replicating when there is physics and desync starts. you have to run physics on server then update to clients but that has nothing to do with your problem from what I can see that is single player your doing. you could stop simulating physics during the teleport and then start it back up how you want it to go thru. if It doesn't work cheat lol. thats what ive learned.

    Comment


      #3
      Originally posted by Damnationist View Post
      STRANGE. I know that objects stop replicating when there is physics and desync starts. you have to run physics on server then update to clients but that has nothing to do with your problem from what I can see that is single player your doing. you could stop simulating physics during the teleport and then start it back up how you want it to go thru. if It doesn't work cheat lol. thats what ive learned.
      I've kind of had that idea as well. I have a bit of trouble doing it in practice though. I want to disable "Simulate physics" on all actor components when an actor overlaps, teleport the actor and then enable "Simulate physics" again. The problem though is that I don't want to enable physics simulation for ALL components after it teleports. I only want to enable physics simulation on the components in the actor that were previously enabled (before the teleport).

      Also, what happens if you enable/disable "Simulate physics" on a component that doesn't have that option?

      Comment

      Working...
      X