Announcement

Collapse
No announcement yet.

Why is this true bool not firing?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Why is this true bool not firing?

    To make sure the target BP is connected to the true event I tested it on an event begin play and it works perfectly.
    Click image for larger version  Name:	truefirebeginplay.JPG Views:	1 Size:	36.7 KB ID:	1641216
    Click image for larger version  Name:	TrueFire.JPG Views:	1 Size:	134.6 KB ID:	1641217

    However, when I set the bool to a pain event it does not fire. To make sure the pain event was working I had it play a sound when it caused pain.
    Click image for larger version  Name:	TrueNotfirePain.JPG Views:	1 Size:	74.6 KB ID:	1641218
    Click image for larger version  Name:	Truenotfire.JPG Views:	1 Size:	112.5 KB ID:	1641219

    Is there any reason this bool will not fire from an event like a pain volume? What I was trying to do was get it to fire off from an on hit event but there is no way to see the graph when you are in VR hence the reason for setting up the pain volume. Either way it doesn't work.

    Edit: The target BP is using an event tick if that helps
    Click image for larger version

Name:	eventtick.JPG
Views:	1
Size:	78.6 KB
ID:	1641221
    Last edited by tcla75; 07-11-2019, 02:36 PM.

    #2
    Not a single image of it being set to false.
    what is the default value and how are you cycling it?

    Comment


      #3
      Originally posted by MostHost LA View Post
      Not a single image of it being set to false.
      what is the default value and how are you cycling it?
      Its default value is unticked and as far as I am aware you don't need to set it to false for a hit event like a projectile. Anyway you can see the bool does work for an event begin play just not a projectile hit

      Comment


        #4
        Hello there tcla75

        You do need to call the "Apply Damage" event upon projectile collision. Where is the code to Apply Damage event on project collision?

        ExORION Sci-Fi FTPS: Battle Kaiju, Mutants, Techno-Terrorist in Alien Powered Super Suit...

        Comment


          #5
          Originally posted by TechLord View Post
          Hello there tcla75

          You do need to call the "Apply Damage" event upon projectile collision. Where is the code to Apply Damage event on project collision?

          Why am I calling the apply damage event? I tried anyway and it returns errors see below.

          Click image for larger version

Name:	applypointdamage.JPG
Views:	1
Size:	173.9 KB
ID:	1641276Click image for larger version

Name:	applypointdamage2.JPG
Views:	1
Size:	87.0 KB
ID:	1641277
          Click image for larger version

Name:	applypointdamage3.JPG
Views:	2
Size:	107.8 KB
ID:	1641279
          Attached Files

          Comment


            #6
            Click image for larger version

Name:	AAAEvent.JPG
Views:	1
Size:	145.0 KB
ID:	1641281

            Comment


              #7
              Originally posted by tcla75 View Post
              Why am I calling the apply damage event? I tried anyway and it returns errors see below.
              My fault. I overlooked the issue was with "Pain Causing Volume". Matt has video for that node too. Unfortunately, I cannot see the entirety of the blueprint to know whats going on with the hit result, but if its not firing, blocking hit is FALSE. Check your Collision Channels Settings.


              ExORION Sci-Fi FTPS: Battle Kaiju, Mutants, Techno-Terrorist in Alien Powered Super Suit...

              Comment

              Working...
              X