Announcement

Collapse
No announcement yet.

(4.22) Whenever I open my project, struct is converted to "Fallback Struct"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    (4.22) Whenever I open my project, struct is converted to "Fallback Struct"

    Not sure why this started happening but suddenly in a blueprint that hasn't been modified in a long time whenever I load up my project I see this

    https://i.imgur.com/PueLGkA.png

    I'm assuming something went wrong in the loading process and it couldn't load the proper "InventoryEntry" struct it was supposed to so it converted it. If I mouse over the "Hotbar Data" on the spawn actor node, I see it's looking for an array of Fallback Struct Structures for some reason

    https://i.imgur.com/5arEc9u.png

    If I right click my Spawn Actor node and click Refresh Nodes then mouseover Hotbar Data again, I see that it's been corrected and I can re-link everything. This is super obnoxious to have to do every time - is there anything I can do about it?

    Edit: It's these kinds of issues that really make me dislike UE4. The engine is clearly having an issue but instead of actually displaying what the issue is, the engine implements some kind of "patch" for it and pretends it never happened. There's no support for the issue and nowhere to reliably turn for help. I've found several posts about this issue and all seem to have gone unresolved. The best people have come up with is re-naming (sometimes this works) or re-making the struct in question.. which is a bit ridiculous to have to do.
    Last edited by Chumble; 07-11-2019, 10:10 AM.

    #2
    Been having this issue on 4.20 as well. I can fix it by going over the struct right clicking and going to Asset Actions > Reload. Problem is when the project is re-opened it reverts back to a Fallback struct and I can't seem to find a proper solution.

    Comment

    Working...
    X