Announcement

Collapse
No announcement yet.

Ignore collision of component in same instance but not on other instances of same class

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ignore collision of component in same instance but not on other instances of same class

    Hey there,
    I have some enemies created like in this livetraining: https://www.youtube.com/watch?v=lFpXqggbUP4

    Now there´s a little problem, some enemies are longer than the sphere which is colliding with the spheres of other enemies (like on snake)...
    If I would scale the sphere up to overlap the complete enemies mesh, no enemy can pass by the side in some meters.
    If I let the scale be the same, other enemies are overlapping the mesh.


    My option was to set the skeletal to block the sphere, but then the enemy would fly around or just freak out...

    Nodes "Ignore Actor When Moving" and "Ignore Component When Moving" isn´t working, because the sphere is simulating physics, read there: https://api.unrealengine.com/INT/Blu...ing/index.html


    Is there any other way available to let the sphere ignore the skeletals collision of the same instance but not on others?
    Click image for larger version  Name:	enemies.png Views:	1 Size:	36.5 KB ID:	1641165
    Last edited by Killerzwerg; 07-11-2019, 01:44 PM.

    #2
    Anyone have an idea how to do this?

    Comment


      #3
      An approach, although a hacky one, would be to make multiple collision channels like "Team1" & "Team2" and set their collision responses accordingly when they spawn.
      But not a viable option if you have multiple enemies in a free for all, since you can't have infenitely many collision channels.
      If you don't have the need for it to get blocked for physics/constraining reasons you could use OnOverlap to check if they're allowed to do things.
      Hope you can find a solution.

      Comment


        #4
        Thanks, but I have too many enemies...
        I was hoping there´s any way I was not trying before, but **** happens^^

        Comment

        Working...
        X