Announcement

Collapse
No announcement yet.

Help: Wall Climbing Blueprint with Automatic Ledge Climb

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help: Wall Climbing Blueprint with Automatic Ledge Climb

    Hey all. First before anyone says google the subject, I assure you that I have googled this and found plenty of answers but none with the type of system I'm looking to make here. I've tried to combine two different kinds of systems to create the desired effect but it doesn't seem to ever work. Basically I'd like a climbing system that let's the player climb up certain surfaces (I've gotten this handled successfully using overlaps on colliders on the climable surfaces) and then at the top I'd like it to automatically play a root motion controlled animation to climb the ledge and place the player at the top of the ledge. I can do line traces all day long and detect the ledge and measure distance between my character's pelvis and the ledge to tell it to grab the ledge. From there I could easily use the AnimBP to play the montage with the root motion animation in it but something with the climbing volume seems to be interfering with the ledge grab logic. I wondered if anyone had done a system similar to what I'm trying to do and if they could point me in the right direction if so. Thanks!

    #2
    I would go around it the other way, hand IK bones or sockets for the grab spot.
    and if the feet get to the same z as the hands you know that the montage is almost done and you can manipulate the capsule position via root bone movement.

    Other that that, without a video of the problem it's kinda hard to understand what is happening...

    Comment


      #3
      MostHost LA Thanks for the response. Yeah I didn't wanna get into posting the various parts of the blueprints and explaining how they tied together if someone might have had a method they used or a tutorial that did it in a way that was more efficient than my setup. I think I figured my problem out though. I had a function that was relying on the wrong bool to fire.

      Comment


        #4
        aptemplate had some climbing in it. I dont think there are animations, but everything worked functionally. https://forums.unrealengine.com/comm...ion-platformer

        Comment


          #5
          thadkinsjr Awesome thanks!

          Comment

          Working...
          X