Announcement

Collapse
No announcement yet.

Teleportation/Checkpoint error, bug, issue, confusion, perplexity, you choose.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Teleportation/Checkpoint error, bug, issue, confusion, perplexity, you choose.

    I had a checkpoint system set up nice and perty. You hit a collision box before falling off a screen it registers and saves the actors location, hit death collision box respawn simple right. Well, it worked fine for weeks even. Then 3 days ago it broke for no apparent reason. So I whittled away at it trying to make it work again. Since I really only need teleportation it should be easy but no still nothing. So I settled for another route which was you reach terminal velocity along z (around -4000) and you respawn oh that worked quite nice and it was all in one blueprint so it registered easier I presumed.

    Well, I made it fancy even had it reverse how you fell and put you back as if you rewound time sorta. Guess what, another crash at some point..... and broken. Would not work at all made me very sad because it was really cool how it worked. Okay, screw it lets just go with the bare bones. I have been legit picking at this for almost two days and this is just the results it makes no sense to be honest. It is constantly respawning me at 0,0,0 unless some function that is not set but is set manually is plugged in albeit the collision is registering and saving my numbers.

    Here this video should explain it better. I opened up a blank project and tried when actor overlaps collision box, register location, set it. Then when the player exits the box or end overlap have a delay then teleport actor back to the overlapped location and it did not even work. So the fact this is working is somehow a bloody miracle I guess. Not sure if vectors are broken or something else. I have narrowed it down to the vector not setting or registering properly since it wishes to go with the default value of 0,0,0 unless manually overridden.

    https://www.youtube.com/watch?v=UDyb1ZVzruc
    Last edited by Mundi Umdali; 05-25-2019, 11:12 PM.

    #2
    Been trying all kinds of things after this and I almost got somewhere with a gate, event tick, do once added in, but it only worked one time. Then it sorta tried to work again but put me in thin air, then reverted back to 0,0,0. Not quite sure what is wrong.

    Comment


      #3
      Hi, Mundi.

      Could you please share your Blueprint through https://blueprintue.com/? It's much easier to analyse than screenshots or a video.

      Drag out of your Cast node's As Player Character pin and plug that into the Get Actor Location you have right next to it. I believe that should solve your issue.
      Last edited by DanDizard; 05-27-2019, 08:49 AM.

      Comment


        #4
        I fixed it by stuffing the same exact thing I had not working into player BP. People said I shouldn't do it but it worked.

        Comment


          #5
          It basically was player begin overlap, get actor location, set actor location to the variable, when actor overlaps death actor/box get set actor location, teleport actor to said location. It would set me to 0,0,0 unless I manually overwrote that. Also, the suggestion of getting actor location fails greatly in that blueprint in the Player BP getting actor location does the 0,0,0 glitch but world location works. However, neither worked when it was in the checkpoint BP.

          Comment

          Working...
          X