Announcement

Collapse
No announcement yet.

"Collision Handling Override" for SpawnActor doesn't work as expected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Collision Handling Override" for SpawnActor doesn't work as expected

    Hi,

    Is written in the title, I have problems with the "Collision Handling Override" option here. I'd like to spawn the actor only if he doesn't overlap with another actor. So I set this option to "Do Not Spawn". I spawn these Actors on a 100units grid (Image 1). I expected this to work if the actor is exactly 100x100 units wide, however, this didn't work. So for testing purposes, I set the actor to something around 95x95 units. As you can see in image 1, the actor very obviously doesn't overlap with his neighbors in the grid. Image 2 is the collision boxes (simple an complex both activated). However, image 1 is shot with the option set to "Always Spawn, Ignore Collisions". If I set this option to "Do Not Spawn" (which is the option I want, cause this actor can have bigger meshes depending on the game situation, and I don't want him to spawn if he really overlaps with other actors), I am only able to spawn my example actor every other grid slot (Image 3).

    Can anyone explain to me why this "Collision Handling Override" option works like this? Cause the actors obviously wouldn't overlap when placed on the grid next to each other... How can I fix that, so I'm able to spawn these actors next to each other when their size is 100x100units or less, but can't spawn them when their size is between 101x101 and 300x300?

    Thx for every little help u can give me, even if its only guessing!


    Cheers, Heraklit
Working...
X