Announcement

Collapse
No announcement yet.

Main Menu and Settings Menu error with Back Button

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Main Menu and Settings Menu error with Back Button

    Hi guys
    I made this main menu:

    Click image for larger version

Name:	Main-Menu.jpg
Views:	1
Size:	62.3 KB
ID:	1569525

    From this I can go to Settings menu:

    Click image for larger version

Name:	Settings_2_comment.jpg
Views:	1
Size:	89.2 KB
ID:	1569526


    When I set graphic and click on Apply button it save settings. If I stop the simulation here and then run it again, and go to settings, I have all saved custom settingssaved fine.
    But...
    If I click on Back button, to return to Main Menu and them click again on Settings menu, I have this:



    Click image for larger version

Name:	Settings_3_comment.jpg
Views:	2
Size:	130.0 KB
ID:	1569528

    it would seem that every time I open the Settings menu there is an overlap of instructions for the radiobuttons selections, how do I solve it?

    This is the error:

    Click image for larger version

Name:	error.jpg
Views:	1
Size:	429.6 KB
ID:	1569529

    and this is the graph:

    Click image for larger version

Name:	graph.jpg
Views:	1
Size:	445.2 KB
ID:	1569530


    I ask for your help

    Thank you all
    Attached Files

    #2
    no one please?

    Comment


      #3
      I do dot know how saving/loading works but i would try to run 'Does save game exist' first and connect it with the branch using the return value as condition. Then if false continue with 'widgets of all class' if true 'Load Game from slot'

      Comment

      Working...
      X