Announcement

Collapse
No announcement yet.

Project packaging issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Project packaging issue

    Hello, everyone! I've got an unknown problem with packaging. It's all going well until some moment. And it don't show anything my PC juct stops and I need to restrt it. I don't know very much about packaging so maybe there is a proper way and more save to do it instead of just clicking button "Package".

    #2
    You might try find the log file and post it here for us to at least see what was the last operation done while packaging. The packaging process is a CPU intensive task and it might happen you are overheating, or you don't have enough voltage going to your CPU, or when the tasks for the packaging happens the antivirus might be disturbing the process or even disk errors might corrupt the whole process. What to check:

    - for CPU, download a tool like Cinebench R15 and make it run few times and see if your system hangs (Blender renders on CPU might be as good as Cinebench to test this)
    - for antivirus, try to disable it while packaging
    - run a diagnostic for your hard disk/ssd
    - get the log found at folder "project_folder/Saved/Logs/project_name.log" and attach it here so we can take a look

    Hope it helps!
    Nilson Lima
    Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
    Join us at Discord: https://discord.gg/FUwTvzr

    UE4 Marketplace: Cloudscape Seasons
    supporting: Community FREE Ocean plugin

    Comment


      #3
      I've tested my computer with blender scene and it all was well also it can handle work with 4k texture in real time without lagging. I've tried to package my project without antivirus and it failed again. This is a log from my latest try. I also noticed that it crashes at the same step each time. When remaining is 883 or 882 it always stops. This is link to the output log file on google disk: https://drive.google.com/open?id=1T1...rMmpXMOEbApjoQ

      Comment


        #4
        OK some questions and points now:

        a) Did you ever successfully packaged that project into UE 4.21?
        - If yes, did you recently added any package into that project?
        - If no, did you ever successfully packaged that project in any UE version?
        - if yes, did you move the project from its usual location?

        b) There are several linker errors, which seems to be long path+file names, there is a limit which Unreal can handle. Most of the issues points to Brushify asset regarding this... they were so many...

        c) some old assets are in use and seems they need to be resaved (maybe the project is being from old UE version and brought to 4.21), and you need to enter each one resave them, and by last try to package again.

        Nilson Lima
        Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
        Join us at Discord: https://discord.gg/FUwTvzr

        UE4 Marketplace: Cloudscape Seasons
        supporting: Community FREE Ocean plugin

        Comment


          #5
          Yes, I have packaged my project successfuly one time, but this was a long time ago and there were much smaller amount of files in it and I did with 4.20 version I guess. How can try to solve a problem with long path+file names.

          Comment


            #6
            I've tried to cook my project, after activating valifator on problem folder and editor packeged it without crash, but unfortunatly cook failed with ExitCode=25 (Error_UnknownCookFailure). Also output log said to go to specific folder and see output log. Actually I don't understand what's the problem. This is a link to the ouput log from folder C:\Users\asus\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Engines+UE_4.21 https://drive.google.com/file/d/1bhl...ew?usp=sharing

            Comment


              #7
              The log shows 7 errors and 791 warnings that might cause packaging issues aswel.

              You need to fix these first and see if the list reduces:

              LogProperty: Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/_WEAPONS/Pistols/BluePrints/Pistols_Child/MainGun_BP.MainGun_BP_C:ExecuteUbergraph_MainGun_BP.CallFunc_GetDataTableRowFromName_OutRow'. Unknown structure. ProcessResult.StdOut: LogInit: Display: LogBlueprint: Error: [Compiler Stas_AnimBP] The property associated with IK Offset Foot Right could not be found in '/Game/_HEROES/Stas/BluePrints/Stas_AnimBP.Stas_AnimBP_C' from Source: /Game/_HEROES/Stas/BluePrints/Stas_AnimBP.Stas_AnimBP ProcessResult.StdOut: LogInit: Display: LogBlueprint: Error: [Compiler Stas_AnimBP] The property associated with IK Offset Foot Left could not be found in '/Game/_HEROES/Stas/BluePrints/Stas_AnimBP.Stas_AnimBP_C' from Source: /Game/_HEROES/Stas/BluePrints/Stas_AnimBP.Stas_AnimBP ProcessResult.StdOut: LogInit: Display: LogBlueprint: Error: [Compiler Ue4ASP_Character] Spawn node SpawnActor NONE must have a Class specified. from Source: /Game/AnimStarterPack/UE4_Mannequin/Player/Ue4ASP_Character.Ue4ASP_Character ProcessResult.StdOut: LogInit: Display: LogBlueprint: Error: [Compiler Ue4ASP_Character] In use pin Instigator no longer exists on node SpawnActor NONE . Please refresh node or break links to remove pin. from Source: /Game/AnimStarterPack/UE4_Mannequin/Player/Ue4ASP_Character.Ue4ASP_Character


              There are reported several files missing during cook process, so I think you need to create another empty project and start Migration process from this project to the new one, best approach would be start migration right-clicking on a map/level which should migrate the most of the useful content. The migration process uses references from one asset to the other and only things that are used will be transfered.
              Nilson Lima
              Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
              Join us at Discord: https://discord.gg/FUwTvzr

              UE4 Marketplace: Cloudscape Seasons
              supporting: Community FREE Ocean plugin

              Comment


                #8
                So I've made it another way. The problem causing assets are the once, which I don't use and don't think to use. So I simply delte them from content directory and that's all. I've finaly packaged my project. Thank you very much for help!

                Comment


                  #9
                  Originally posted by GlebDot View Post
                  So I've made it another way. The problem causing assets are the once, which I don't use and don't think to use. So I simply delte them from content directory and that's all. I've finaly packaged my project. Thank you very much for help!
                  Glad to hear you got this working.

                  The linker errors you got may have been caused by moving folders outside of Unreal Engine. In order for assets to remain linked correctly folders must be moved within the content browser, this makes sure that they stay connected.
                  Brushify is a complete landscape solution and shader infrastructure for Unreal Engine 4.
                  Get Brushify on Unreal Marketplace: www.brushify.io

                  Comment

                  Working...
                  X