Announcement

Collapse
No announcement yet.

Picking up a Rune - guide a new user please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Picking up a Rune - guide a new user please

    Hello! I am very new to blueprints and I am stuck in a very basic issue. I want my player to pick up a rune and set its boolean to true once he picked it up. Now, I don't want my player to pick another rune for as long as he has his boolean to true. Here is what I made, it's something simple I thought would work.



    I thought my branch will check the boolean variable and if set to 1 already it would fail the branch. I am getting this very wrong. Please help!
    Attached Files
    Last edited by WWM; 09-18-2018, 12:41 AM.

    #2
    While on topic, I also want my HUD to change a brush the moment the boolean becomes true (the moment the rune is picked) but for some reason even this issue gives me trouble as I get compiling errors that I don't understand. Here is how my widget looks like:

    Click image for larger version

Name:	question_2.jpg
Views:	4
Size:	175.7 KB
ID:	1529087
    Click image for larger version

Name:	question_2b.jpg
Views:	5
Size:	24.3 KB
ID:	1529086

    Comment


      #3
      You have not connected cast-nodes^^
      Click image for larger version

Name:	Unbenannt.jpg
Views:	6
Size:	145.1 KB
ID:	1529104

      Same issue in the second screenshot. The cast is never performed but its result shall be used as condition for the branch. That's not going to work ;-)
      I also don't see, why you have that second cast there anyway? you should directly retrieve the "PickRune" bool from the first "asVilliagerIvan" and use that as the condition, I would assume...
      Check out my GTA2 remake in UE4

      Comment


        #4
        Thanks a lot! At my stage I am making stupid mistakes like this one. The first issue is now resolved, thanks to you. On the second issue, I still cannot display the brush change on the HUD. A rune Icon should appear where I have pointed with the red arrow but nothing happens. Not only that, but I have that weird white button there in its place.

        Also, i feel i am doing the brush change wrong (in a bad way). I have an empty png button that should switch to a nice rune looking when the villager picks the rune. I feel like I should just place the rune.png there and trigger the opacity of the image, but I do not know how.

        Click image for larger version

Name:	question_3.jpg
Views:	6
Size:	168.8 KB
ID:	1529118Click image for larger version

Name:	question_3b.jpg
Views:	4
Size:	21.6 KB
ID:	1529119

        Comment

        Working...
        X