No announcement yet.

Does not work on Standalone, Works on Editor (PIE)

  • Filter
  • Time
  • Show
Clear All
new posts

    Does not work on Standalone, Works on Editor (PIE)

    I have been working on an RPG for too long, it has no errors and I managed to make it as optimized as possible.

    Today, when trying the standalone, an actor component isn't detected by the game anymore. It doesn't even launch the event begin play or the event tick while everything works properly in the PIE
    (-tried with delays
    -upgrading from UE4.19.2 to UE4.20
    -ticked autoactivate
    -in the actor, on component activate shows that it's activated at the beginning of the game, however, still same problem
    -validating assets/fix up redirectors in folders/refreshing all nodes
    -recompiled every bp one by one
    -cleared the saved folder)
    (yesterday it was working fine, it did this after shutting down and turning on the pc today)

    also, upon checking if "is valid" it displays for me that it's valid and it exists in both PIE and standalone but it seems like in standalone it is not working/ so probably desactivated.
    the attachment : The component event tick, shows in the PIE and doesn't show in the Standalone.

    I worked on this for 1 year now, it's not really pleasing to experience this..
    Thank you in advance, I'd appreciate all the help!

    Hello..i know im soo late...this is for anyone who has similar problems...i dont know if this is a fix but if u are using any array on your component make sure to clear the elements before u add any item to it..