Announcement

Collapse
No announcement yet.

on touch/click where do i enable these?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by lamascsi View Post
    The playercontroller class (the default or your custom) has those settings. Also make sure that the input is consumed properly (like not by UI, you can set that with bp nodes for example on event beginplay)
    Okay...it's not working.

    On event begin play set click events enabled to true. I do the same for touch events.

    Monster has a on touch/on click (tried mesh and capsule) to a print string.
    and I removed the Widget code from the character so I know it wasnt in the way. Unless the default virtual joystick is.

    Any ideas? Is there more to setting it up than just turning it on?

    Leave a comment:


  • replied
    Originally posted by lamascsi View Post
    The playercontroller class (the default or your custom) has those settings. Also make sure that the input is consumed properly (like not by UI, you can set that with bp nodes for example on event beginplay)
    Took me a bit.
    My controls were simple enough i was controlling in the pawn, no player controller.
    So i had to turn of context sensitivity.....
    very clear node: enable click events.

    thanks..

    guess i get to redo everything for a player controller BP now

    Leave a comment:


  • replied
    The playercontroller class (the default or your custom) has those settings. Also make sure that the input is consumed properly (like not by UI, you can set that with bp nodes for example on event beginplay)

    Leave a comment:


  • started a topic on touch/click where do i enable these?

    on touch/click where do i enable these?

    Was thinking about replacing my twin stick shooter with a single stick with lock on.

    First thing i was going to do was set all the monsters to you can click/tap on them to target them.
    There are nodes for this "on click" and on touch". I just hooked them to a print string to test them "enemy targeted"

    And they dont work.
    It says on the nodes "if enabled in user input"

    went through the input section and cant find a tick box. Is there something i am missing? or something else I need to do? I would appreciate a finger in right direction
Working...
X