Announcement

Collapse
No announcement yet.

"Actor Has Tag" Doesn't work when the Tag is a variable.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Actor Has Tag" Doesn't work when the Tag is a variable.

    The title says it all.
    Just wanted to know if this is a bug or if I am just overlooking something.
    Essentially the blueprint below works perfectly fine like that, but when I connect the Generic Explosion Tag and Generic Enemy Tag variables into the Tag field from Actor Has Tag it doesn't work anymore.
    Both Generic Explosion Tag and Generic Enemy Tag have the correct Name set in the Class Defaults.

    Click image for larger version

Name:	Screenshot_1.png
Views:	92
Size:	138.5 KB
ID:	1490345

    #2
    Bezoro

    'Actor-Has-Tag' is a heavily used node, especially in loops etc...
    It seems unlikely the node is to blame. Which Engine version?
    What have you done to rule out unhealthy code assumptions...

    Debugging:

    Is a Watch or Print-String always used to check on these 2 vars?
    Are the Tag vars being reset (forgetten code) or suffer from this?
    Could the Actor-Reference ever turn out to be None sometimes?...

    Comment


      #3
      Originally posted by franktech View Post
      Bezoro

      'Actor-Has-Tag' is a heavily used node, especially in loops etc...
      It seems unlikely the node is to blame. Which Engine version?
      What have you done to rule out unhealthy code assumptions...

      Debugging:

      Is a Watch or Print-String always used to check on these 2 vars?
      Are the Tag vars being reset (forgetten code) or suffer from this?
      Could the Actor-Reference ever turn out to be None sometimes?...
      Thanks for your time.
      It was indeed an oversight on my part, I had 2 different bombs inheriting from a bomb base class, one child was behaving correctly but not the other. Turns out that the tags were set to None in one but had the correct values in the other.
      Now I hope to god I don't ever have to deal with the problem from your link, that sounds scary as hell.

      Comment

      Working...
      X