Announcement

Collapse
No announcement yet.

"Accessed None trying to read property and from function" But the other object works just fine?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Accessed None trying to read property and from function" But the other object works just fine?

    In this blueprint I'm referencing three objects to be detected when inside of a box trigger I have created. One of these objects is the player, which is detected and does what I want it to do. However, the two other objects do not, and I get these errors which related to these two objects:

    'Blueprint Runtime Error: Accessed None trying to read property K2Node_DynamicCast_AsMilk_Carton_BP from function: 'ExecuteUbergraph_CheckoutConveyor_Blueprint' from node: Add Impulse in graph: EventGraph in object: CheckoutConveyor_Blueprint with description: Accessed None trying to read property K2Node_DynamicCast_AsMilk_Carton_BP
    Blueprint Runtime Error: Accessed None from function: 'ExecuteUbergraph_CheckoutConveyor_Blueprint' from node: Add Impulse in graph: EventGraph in object: CheckoutConveyor_Blueprint with description: Accessed None
    Blueprint Runtime Error: Accessed None trying to read property K2Node_DynamicCast_AsConk_Can_BP2 from function: 'ExecuteUbergraph_CheckoutConveyor_Blueprint' from node: Add Impulse in graph: EventGraph in object: CheckoutConveyor_Blueprint with description: Accessed None trying to read property K2Node_DynamicCast_AsConk_Can_BP2
    Blueprint Runtime Error: Accessed None from function: 'ExecuteUbergraph_CheckoutConveyor_Blueprint' from node: Add Impulse in graph: EventGraph in object: CheckoutConveyor_Blueprint with description: Accessed None'
    I've included an image below showing the code that is being used.

    If you're curious what this code is for, it's for the player and the two other objects to be pulled along a conveyor belt. The players are successfully pulled a long, but the other objects are not, so I assume this error has something to do with it. However, I'm not entirely sure what it means. If anyone can provide me with some answers, help or advice I'll happily take it.

    Click image for larger version

Name:	CodeProbpsd.png
Views:	11
Size:	190.5 KB
ID:	1459187
    Attached Files

    #2
    You need to use "AddImpulse" separately for each object.
    Currently, each pin of the Sequence node is trying to AddImpulse to all of the overlapping actors. You are trying to access actor's mesh even if CastTo fails, what results in errors.

    Comment


      #3
      Originally posted by exadi View Post
      You need to use "AddImpulse" separately for each object.
      Currently, each pin of the Sequence node is trying to AddImpulse to all of the overlapping actors. You are trying to access actor's mesh even if CastTo fails, what results in errors.
      Thank you so much! That fixed the error! Now the only issue I have is that the objects aren't actually being pulled along, but they do get pulled along when they're in the air. Below I have included an image, it doesn't show much in terms of motion, but it might give an idea to those that could help me with this issue. The players (the balls) are pulled along just fine, but the other objects just aren't moving for some reason.
      Attached Files

      Comment

      Working...
      X