Announcement

Collapse
No announcement yet.

On mouse click event won't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    On mouse click event won't work

    Hello I am trying to make a mesh disappear on the mouse click event

    First, I set show muse coursor to true in character blueprint

    Then
    I tried to set up a class for the mesh. I set it up, made an on click event, dragged off a destoy actor node, and it didn't work. Then I replaced it with a print string "hello", didn't work as well
    It works on hit event, but not mouse click event
    I also tried on begin mouse over or something, didn't work
    Please help, what am I doing wrong?

    #2
    In your player controller you have to enable mouse click events in the class defaults
    YouTube channel: https://m.youtube.com/channel/UC1qaQM1VnY441J5lCLCPMwg

    Comment


      #3
      Originally posted by Ispheria View Post
      In your player controller you have to enable mouse click events in the class defaults
      Hello, thanks but in my third person character blueprint there are no mouse related stuff in class defaults or settings, I was able to set mouse over events via a node, but I don't need mouse overs please halp

      Comment


        #4
        Like I said, it's in your Player Controller not your character. Your 3rd person character is the thing your player controller controls.

        https://docs.unrealengine.com/en-us/...seControlSetup

        Note the 5th picture, the checkbox that says "Enable Click Events". You might as well also set Show Mouse Cursor to be true here too if it's always true.
        YouTube channel: https://m.youtube.com/channel/UC1qaQM1VnY441J5lCLCPMwg

        Comment


          #5
          [Solved]
          I have similar problem but in the AR Template:

          Click image for larger version  Name:	UE4.png Views:	1 Size:	140.7 KB ID:	1525274 I've working on a project for a while then i´ve encountered this problem, after trying so many things, i've started a new template, and the problem still presists.
          This might be some setting that i be missing to turn on, but for now i dont seem to understand what's happening.


          project setting -> filtering with "mouse" -> uncheck USE MOUSE FOR TOUCH
          Last edited by Invius; 09-08-2018, 06:18 AM.

          Comment


            #6


            Anymore I just do a trace like this for my object ref and do the rest with interfaces.

            And you can do a bit of work with tags and such if you want to be able to set actors to do X or Y on click as well.
            Last edited by scurv; 09-08-2018, 10:49 AM.

            Comment


              #7
              You might have to try "Use Mouse for Touch. For some reasons, the Line Trace doesn't work the same in editor mode.

              Attached Files

              Comment

              Working...
              X