Announcement

Collapse
No announcement yet.

[Advanced Sessions] Second Servertravel command leads to World NetDriver shutdown SteamNetDriver_0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Advanced Sessions] Second Servertravel command leads to World NetDriver shutdown SteamNetDriver_0

    My game recently installed the Advanced Sessions plugin for version 4.16. For my game, players load into a lobby map. The host then initiates the first server travel for gameplay; I have had zero issues here. Once the game is ended the host server sends the second command servertravel /game/maps/lobby?listen to return players back to the lobby to switch teams or whatever. This second server travel however drops all the clients but the server is able to be found by all clients when they search again.

    I only came across this issue since I installed the Advanced Sessions plugin. The basic Create Session node had no issues with server travel across clients. I have also tried setting the Game Mode's Player State to the default Player State. (I am reluctant to remove Advanced Plugins because of its features).

    Why are clients being dropped on the server travel listed below?

    Here is the Server Log
    Code:
    [2018.03.10-04.07.53:600][494]LogEngine: Server switch level: /Game/Maps/Lobby?listen
    [2018.03.10-04.07.53:600][494]LogNet: Browse: /Game/Maps/Lobby?listen
    [2018.03.10-04.07.53:600][494]LogLoad: LoadMap: /Game/Maps/Lobby?listen
    [2018.03.10-04.07.53:601][494]LogNet: World NetDriver shutdown SteamNetDriver_0 [GameNetDriver]
    [2018.03.10-04.07.53:601][494]LogNet: DestroyNamedNetDriver SteamNetDriver_0 [GameNetDriver]
    [2018.03.10-04.07.53:601][494]LogExit: GameNetDriver SteamNetDriver_0 shut down
    [2018.03.10-04.07.53:602][494]LogScriptCore:Warning: Script Msg: DestroySession - Invalid player state
    [2018.03.10-04.07.53:669][494]LogMemory: Platform Memory Stats for WindowsNoEditor
    [2018.03.10-04.07.53:669][494]LogMemory: Process Physical Memory: 378.23 MB used, 496.54 MB peak
    [2018.03.10-04.07.53:669][494]LogMemory: Process Virtual Memory: 1057.96 MB used, 1287.88 MB peak
    [2018.03.10-04.07.53:669][494]LogMemory: Physical Memory: 2568.25 MB used,  5621.30 MB free, 8189.55 MB total
    [2018.03.10-04.07.53:669][494]LogMemory: Virtual Memory: 1698.58 MB used,  5621.30 MB free, 134217728.00 MB total
    [2018.03.10-04.07.53:669][494]LogMemory:
    [2018.03.10-04.07.53:669][494]Allocator Stats for binned2: (not implemented)
    [2018.03.10-04.07.53:681][494]LogAIModule: Creating AISystem for world Lobby
    [2018.03.10-04.07.53:681][494]LogLoad: Game class is 'LobbyGM_C'
    [2018.03.10-04.07.53:681][494]LogTemp:Display: ParseSettings for GameNetDriver
    [2018.03.10-04.07.53:682][494]LogTemp:Display: ParseSettings for SteamNetDriver_1
    [2018.03.10-04.07.53:682][494]LogTemp:Display: ParseSettings for GameNetDriver
    [2018.03.10-04.07.53:682][494]LogNet:Display: SteamNetDriver_1 bound to port 7777
    [2018.03.10-04.07.53:682][494]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
    [2018.03.10-04.07.53:682][494]LogNet: GameNetDriver SteamNetDriver_1 IpNetDriver listening on port 7777
    [2018.03.10-04.07.53:685][494]LogWorld: Bringing World /Game/Maps/Lobby.Lobby up for play (max tick rate 0) at 2018.03.09-20.07.53
    [2018.03.10-04.07.53:686][494]LogWorld: Bringing up level for play took: 0.000856
    Here is the Client Log
    Code:
    [2018.03.10-04.07.54:596][430]LogNet: Browse: steam.76561198020935992//Game/Maps/Lobby?game=/Game/Blueprints/Lobby/LobbyGM.LobbyGM_C?listen
    [2018.03.10-04.07.54:596][430]LogNet: World NetDriver shutdown SteamNetDriver_0 [GameNetDriver]
    [2018.03.10-04.07.54:596][430]LogNet: DestroyNamedNetDriver SteamNetDriver_0 [GameNetDriver]
    [2018.03.10-04.07.54:596][430]LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: 76561198020935992:7777, Name: SteamNetConnection_0, Driver: GameNetDriver SteamNetDriver_0, IsServer: NO, PC: GameplayPC_C_0, Owner: GameplayPC_C_0, Channels: 69, Time: 2018.03.10-04.07.54
    [2018.03.10-04.07.54:596][430]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 76561198020935992:7777, Name: SteamNetConnection_0, Driver: GameNetDriver SteamNetDriver_0, IsServer: NO, PC: GameplayPC_C_0, Owner: GameplayPC_C_0
    [2018.03.10-04.07.54:596][430]LogExit: GameNetDriver SteamNetDriver_0 shut down
    [2018.03.10-04.07.54:596][430]LogTemp:Display: ParseSettings for GameNetDriver
    [2018.03.10-04.07.54:596][430]LogTemp:Display: ParseSettings for SteamNetDriver_1
    [2018.03.10-04.07.54:596][430]LogTemp:Display: ParseSettings for PendingNetDriver
    [2018.03.10-04.07.54:596][430]LogNet:Display: SteamNetDriver_1 bound to port 7777
    [2018.03.10-04.07.54:596][430]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
    [2018.03.10-04.07.54:596][430]LogNet: Game client on port 7777, rate 10000
    [2018.03.10-04.07.54:596][430]LogNet: UPendingNetGame::InitNetDriver: Sending hello. [UNetConnection] RemoteAddr: 76561198020935992:7777, Name: SteamNetConnection_1, Driver: PendingNetDriver SteamNetDriver_1, IsServer: NO, PC: NULL, Owner: NULL
    [2018.03.10-04.07.54:597][430]LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
    [2018.03.10-04.07.54:613][431]LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
    [2018.03.10-04.07.54:629][432]LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

    #2
    [Solved]

    The Game Mode being used during gameplay did not have Seamless Travel enabled.

    When players traveled from the Lobby map the Lobby Game Mode had Seamless Travel Enabled. Upon the second travel command I did not have the Gameplay Game Mode Seamless Travel enabled thus the server dropped its clients.

    Comment


      #3
      the command is ServerTravel and the map name right? Cause i have created a command like this and enabled use seamless travel but it doens't work.

      Comment


        #4
        the command is servertravel /Game/directory to the map file/mapname. For my game the maps are all located in the folder Maps under the Content root in the Editor. Therefore the command for me is servertravel /game/maps/lobby. At the end I declared ?listen to tell the server to maintain an open internet connection. All players that are already connected to the server will travel even without ?listen but, and I may be mistaken on this last part, if you remove ?listen the server will close its door so new players can not join until you create a new session.

        Furthermore I do not know if this is required but I saw this command run in the Game Mode in every tutorial I watched. It could be the only place that server travel is possible...I'm not sure.
        Last edited by Xnar; 03-15-2018, 12:04 PM.

        Comment

        Working...
        X