Announcement

Collapse
No announcement yet.

Slower than normal client replicating?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Slower than normal client replicating?

    Hello,

    I'm doing some experimenting with replicating and have found that client replication seems to be rather slow. I'm using version 4.18 of the engine. But this is an issue I've also encountered in 4.17.
    In following gyazo you can see me switching teams on both the client and the server. For the server this change is always instant (with net.UseAdaptiveNetUpdateFrequency = 0 in the ini files), howerver as you can see on the client it sometimes takes over 1 or even 2 seconds to receive the update. The replicated variable to change teams is an int with 1 digit, which as far as I know should be extremely lightweight and fast to replicate, however this doesn't seem to be the case.

    https://gyazo.com/44f0eb9c1247b7d09bc006d030d832ed

    Anyone know what is causing this delay?

    This is pretty much a clean project with only the team logic in it, nothing else. All project settings are on default. This is also in-editor testing which should make the connection almost instantly fast, right?

    On a sidenote one other thing I've noticed is that the "Gamestate" is never valid the first second a widget is created. I fetch the Gamestate class with a doonce on tick which first checks if it's valid and only then do I promote it to a variable. This always happens after around a second. Why is this?
    Last edited by WixZ; 12-18-2017, 08:31 AM.
Working...
X