Announcement

Collapse
No announcement yet.

[4.17.2] What is causing my ToolTip's position to flicker between different screen locations?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [4.17.2] What is causing my ToolTip's position to flicker between different screen locations?

    My positioning setup is in the image below:.

    TargetPositionX and TargetPositionY is an actor's worldspace position converted to a screen location using the ConvertWorldLocationToScreenLocation Node.
    The ToolTip flickers back and forth between the correct position passed in from Hover Radar Icon(via the two floats), and what appears to be the top left position of the Hover Radar Icon.
    Ive checked, and confirmed that Hover Radar Icon is valid when the ToolTip is in the incorrect position.

    I have no other code or script that changes the location of the ToolTip.
    In fact, the only thing that even refrences the ToolTip is Hover Radar Icon, and Standard Macros(IsValid Node).

    Why is it flickering between two positions, and how can I ensure it stays at the correct position?

    #2
    Difficult to tell from that tiny snippet. All i can see is that you check the position and (redraw?) every tick - so i can only guess here. Maybe the redraw on tick (Which is at least every frame) is just too fast and it fires the tooltip every time, de facto reinitializing the tooltip every frame. Maybe you can insert a delay to see if the problem is located somewhere around there. AT least that's my best guess out of the blue.
    My Patreon page (UE4 goodies!)

    Comment

    Working...
    X