Announcement

Collapse
No announcement yet.

Networking line trace weird result.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Networking line trace weird result.

    I have networked my line trace and the destroy actor but when i line trace on the server it will only hit the actor from the front.

    Here is a gif showing what is happening. The hit object is being printed to show whats being hit.
    This is the client as its being started on a dedicated server.
    You can clearly see that im hitting the object but it is only registering it when im basically touching it
    If i set the line trace to multicast it detects the object but it ignores the apply damage so the object does not get destroyed.
    the object is replication.

    Execute on server
    https://gyazo.com/e66951e480218bd0d7dca9c637afcb28

    Multicast
    https://gyazo.com/d1357fa58bce70c56294ab24e457b01d

    Last edited by rapiidzz901; 10-16-2017, 08:07 PM.

    #2
    Originally posted by iamjohngalt1975
    You need this something bad!

    Unreal Engine 4 - (Tutorial) Quick And Dirty Blueprint Shooter Replication



    **I forgot to mention in engine v4.17+ epic somehow broke getting a rotation from the camera boom, so instead in the video where I set up the linetrace get the rotation from the camera as well**

    You are welcome!
    Thanks for this i managed to get an idea of how to do it and was able to easily recreate this in c++, very well made tutorial.

    Comment

    Working...
    X