Announcement

Collapse
No announcement yet.

Level streaming not working as tutorial stated.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Level streaming not working as tutorial stated.

    Hi, Unreal gurus,

    I'm trying out with level streaming in UE4.

    I started an empty 3rd person project with starter contents. And follow this guide extremely carefully.
    https://docs.unrealengine.com/latest...nts/index.html
    The only difference is that I set ThirdPerson default map to persistent level, and the Minimal_Default as "Level to Stream."

    Whenever my player character touch(begin overlap) the LevelStreamer object, the new objects from the Minimal_Default map will added into WorldOutliner for a little while but NOT BEING VISIBLE. (Yes, I did check "Makef Visible Afetr Load" in Load Stream Level call, and I set breakpoint to check the "load stream level" is executed for sure.)

    And after a few second, the new objects just disappear in the World Outliner.
    No matter what, I never saw the streamed map showing up.

    What could be wrong?
    I can provide whole projects if it's needed, thanks.

    #2
    This is the screenshot, where the streamed "Minimal_Default" should be present on the right because I stepped on the LevelStreamer object, even the "Chair" shows up in the World Outliner.

    Comment


      #3
      Hi, all,

      I have discover that this problem is related with camera position.
      When my camera rotate around the character and went out of of ThirdExampleMap, the minimal_default map (as the streamed level) show up properly.
      If I rotate camera back into ThirdExampleMap, the Minimal_Default suddenly disappear and the character fall like the level is remored completely.

      I NEVER trigger the "unload stream level" in BP, thus I cannot understand where does this behavior come from.
      Any idea, please?

      Comment


        #4
        I know this is hella hella old, but, it could be that the overlap begin and end functions should change add unique dynamic to just add dynamic. Seemed to have worked for me.

        Comment

        Working...
        X