Announcement

Collapse
No announcement yet.

Need Help With ADS Hide Third Person Weapon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need Help With ADS Hide Third Person Weapon

    So my issue is that when I aim down sights it switches to a different camera where I have separate arms and a weapon function to handle aiming down sights and what not. For some reason when I ads and set the third person weapon to owner no see I can still see it when I aim down sights. I also have owner no see enabled on the third person character and he works just fine. Ill post some pictures let me know what you guys think could be the problem. Any help would be great!

    https://i.gyazo.com/0a80d5ee0ce61db0...198f835317.gif

    https://i.gyazo.com/b0f08efbbbd63851...0f1db7386c.png

    https://i.gyazo.com/79d3d7f3cf1d5d7e...acd0ac1cab.png
    Attached Files

    #2
    Have you double checked to make sure the weapon has it's owner set?

    HTH
    Never say Never, Because Never comes too soon. - ryan20fun

    Frames Per Second is NOT a proper performance metric, You should use frame time. You can read this or this as to why.
    (Profiling) Tools: RenderDoc (UE4 Plugin), NVIDIA nSight, AMD GPU PerfStudio, CodeXL
    Good articles/Series: A trip through the Graphics Pipeline 2011

    Comment


      #3
      Originally posted by ryan20fun View Post
      Have you double checked to make sure the weapon has it's owner set?

      HTH
      I wrote it like this but it still doesn't want to work. Im sure I am doing this wrong. Maybe I need to hide each weapon individually......I was hoping to do it with the base weapon so that It would hide the mesh regardless of the weapon type.

      Click image for larger version

Name:	2ae5ce456dfe2b650589b862c2f87215.png
Views:	1
Size:	122.4 KB
ID:	1132669

      Comment


        #4
        Originally posted by QFMarine View Post
        I wrote it like this but it still doesn't want to work. Im sure I am doing this wrong. Maybe I need to hide each weapon individually......I was hoping to do it with the base weapon so that It would hide the mesh regardless of the weapon type.

        [ATTACH=CONFIG]152521[/ATTACH]
        Can you not set the Actor to "owner no see"?
        You could try adding a function to the weapon that would handle setting the visibility states for the meshes.

        A possible workaround would be to set the mesh to invisibly locally, But that visibility state may replicate to the other clients.

        HTH
        Never say Never, Because Never comes too soon. - ryan20fun

        Frames Per Second is NOT a proper performance metric, You should use frame time. You can read this or this as to why.
        (Profiling) Tools: RenderDoc (UE4 Plugin), NVIDIA nSight, AMD GPU PerfStudio, CodeXL
        Good articles/Series: A trip through the Graphics Pipeline 2011

        Comment


          #5
          Set the actor for your gun inside your character as the owner, and do the same for any other components inside that gun actor, using the Set Owner node.

          Comment

          Working...
          X