Announcement

Collapse
No announcement yet.

ue4 Super Buggy. It is completely diregarding my configured gamemode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ue4 Super Buggy. It is completely diregarding my configured gamemode

    Hi,

    Have a look at this youtube video:

    https://www.youtube.com/watch?v=az-t...ature=youtu.be

    I'm using 4.16.2 during this.

    a) I have set my gamemode to my own class FOTDGameMode. You can see this at 0:11 in the video.
    b) I set a breakpoint at 0:40 on the OnPostLogin method inside FOTDGameMode so that it will breakpoint when I locally connect.
    c) at 1:06, it is TestCharacter which is the spawned and assigned character, BUT, the FOTDGameMode doesn't reference this character at all to spawn and possess!
    d) at 1:24 I reshow that the default pawn is not TestCharacter, but Player_Character
    e) AT 1:32, I start going through the whole level objects to prove that TestCharacter isn't just on the map with "Auto possess" on.

    So tell me, why is TestCharacter still being spawned and possesed?

    #2
    Are you overriding the level game mode in World Settings? Window -> World Settings.
    Marketplace Assets

    Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
    Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
    Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

    Comment


      #3
      +1 for jamendxman3
      Also:
      1. i dont recommend to use breakpoint, they were not working many times for me, instead use print string
      2. I doubt on post login is called when you run your game through editor, check it with printstring

      Comment


        #4
        Originally posted by Jamendxman3 View Post
        Are you overriding the level game mode in World Settings? Window -> World Settings.
        Thanks. Yes I didn't realise that you can set the gamemode per level in world settings.

        Comment

        Working...
        X