Announcement

Collapse
No announcement yet.

4.16.2 blueprint trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.16.2 blueprint trouble

    Hello all, I have a game where there are guards that look for you but you are able to take them out with darts that your character shoots. I upgraded to unreal 4.16.2 and this code no longer works. It is set up the same as in 4.14.1 does anyone have any suggestions? Did 4.16 make significant changes to blueprint? Thank you.

    #2
    It is really hard to answer your question without providing any information. Either show us your setup or at least tell us what you are doing! If you simply want to know what changes were made to the BP system recently, head to the changelog which will tell you exactly what has been changed.

    Comment


      #3
      If you 'launch' as opposed to play do you get any errors in the output log? Also, does your AI use EQS? Maybe needs to be re-enabled in Editor Settings.

      Comment


        #4
        same error here, i follow so many tutorials, but none of them actually works , i follow this one, and all worked, except the last part, where my player kills the enemy, all of my blueprints are exact the same of the guy in this video , can someone help ?

        Link : https://www.youtube.com/watch?v=lipLWMbyMq0

        Comment


          #5
          Go back and check the setup of blueprints for this system. I had a similar issue when going from 4.15 to 4.16. My previously working vehicle just stopped working. No compile errors or anything obvious. Turned out my wheel setup got cleared and I had to re-select which wheels to use. After that, everything worked fine. No idea why that happened, but maybe something similar happened to you?
          Gooner44
          Cribbage Sample Project on MP

          Comment


            #6
            Thanks for everyone's replies! I'm still having the issue but I figured out whats going wrong. My projectiles are apparently not hitting my guards, they are going through them. I'm not sure if this is an issue with line trace or if the collision of my guards got weird in the update. Anyway, here is the code for shooting if anyone wanted to look at it.Click image for larger version

Name:	blueprint 1.PNG
Views:	1
Size:	153.5 KB
ID:	1130675Click image for larger version

Name:	blueprint 2.PNG
Views:	1
Size:	120.4 KB
ID:	1130676Click image for larger version

Name:	blueprint 3.PNG
Views:	1
Size:	105.1 KB
ID:	1130677Click image for larger version

Name:	blueprint 4.PNG
Views:	1
Size:	92.3 KB
ID:	1130678

            Comment


              #7
              I'm not terribly familiar with damage types and that sort of thing, but you might want to check that. Also, collision presets, etc. I get the feeling when those types of things change in the base code, it resets the setting in blueprint nodes so maybe something you had set up is no longer set that way after the upgrade.
              Gooner44
              Cribbage Sample Project on MP

              Comment

              Working...
              X