Announcement

Collapse
No announcement yet.

Multiplayer Accessed None Property Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Multiplayer Accessed None Property Error

    I try to program a Multiplayer game but my MainWidget keeps sending me the eccessed none error every time i test to run it on a dedicated server with 2 players:
    Error Blueprint Runtime Error: Accessed None trying to read property MainWidget from function: 'ExecuteUbergraph_CharacterBP' from node: Add to Viewport in graph: EventGraph in object: CharacterBP with description: Accessed None trying to read property MainWidget

    #2
    Sounds like you didn't create the widget before trying to add to viewport.

    Post a screenshot of your Blueprint.

    Comment


      #3
      UMG objects are not replicated, in-case you were trying to replicate the widget and add it to several screens.
      Marketplace Assets

      Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
      Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
      Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

      Comment


        #4
        sounds to me like you may need and isvailid? check, a screen shot of the area in the bluperint its throwing the error might get you more specific help
        Come Join Me On Patreon : https://www.patreon.com/iamjohngalt75 Or Visit Me On Youtube : https://www.youtube.com/channel/UCpu...wyusqni1ZnWdBQ

        Comment

        Working...
        X