No announcement yet.

Collision channel settings does not work when both intracting actors are Charcters

  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Created a bug report here:

    UPDATE: The staff has acknowledged the bug
    Last edited by mindfane; 08-02-2014, 02:09 AM.

    Leave a comment:

  • replied
    I replied here

    Leave a comment:

  • replied
    I understand. I use custom channels usually.

    But I ran into this 'issue' by accident. I just want to know if this is a bug or just some qwrong configuration. I am leaning towards a bug becuase removing the MovementComponent from BP_Spider (by extending it from Actor) seems to fix this without any custom channels.

    Thanks for the reply though. Looks like I will have to play around with it.

    Leave a comment:

  • replied
    I'm not sure if that is a bug or not but in my experience, it's better to make some custom channels for your player vs enemies. It makes things easier to deal with. So if every single pawn in the game is simply set to be pawn collision, there's no way to distinguish them from each other. You're either always gonna go through all pawns, or always collide all pawns.

    But if you make a custom channel for enemy and one for player, now you can set things up more specifically, based on those channels. You can take it further and create a custom channel per enemy type if need be. It makes life a lot easier in the long run.

    In my game I also have custom collision channel for my weapons, so I can separate that out completely from the rest of things. So I can make sure the right things always only collide with what they are supposed to.

    Leave a comment:

  • replied
    Can someone help me out here?

    Leave a comment:

  • Collision channel settings does not work when both intracting actors are Charcters


    I dont know if this is a bug or expected result. Here is the issue:
    (this is originally discussed here:

    I have two BPs extended from Character. Lets call them BP_Spider and BP_Player.
    BP_Player is used as my default player pawn.

    In the Capsule compoenent for BP_Spider, I have set
    Collision preset: Custom
    Collsion type: Pawn
    Collsion enable: collsion enabled
    Collsion channel 'Pawn': Overlap.

    In BP_Player, all settings are set at their defaults.

    I put an instance of BP_Spider in the map.

    Eventhough I asked Spider's Capsule to not block any Pawns, it blocks my player pawn (BP_Player)
    Inorder to make it work, I now have to ask the player's Capsule to ignore Pawns too which is not good

    However if I make the Spider a BP extended from Actor (ie without Movementcomponent), it works like it should

    So is this a bug or am I doing something wrong here?