Announcement

Collapse
No announcement yet.

Annoying detach problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Annoying detach problem

    Hi guys!

    So I have a problem. I have a game in which the player can enter a vehicle and then inside he can go into "driving mode". Since the vehicle is a seperate pawn what I do is I posses vehicle pawn and attach the player pawn to it so he stays inside the vehicle. But when I exit the driving mode and detach the player it usually teleports to origin. Does anyone have an idea on are there specific settings in AtachToActor and DetachFromActor that can fix that problem? Or any other clever way of doing it that will work better?

    #2
    Am I asking stupid question or does noone know anything? ;p

    Comment


      #3
      Can't you just set the location of the player to the location of the vehicle?

      Comment


        #4
        maybe create a scene inside the vehicle blueprint that represent the world cords where you want to drop the player off (driver side of car for.example). then "set actor location" on character right before detach ?
        My blog : http://www.thatlittlespider.com

        Comment


          #5
          Yeah, I tried setting location of course, but it has to be inside of the car, since it's a huge vehicle and inside the player has some stations he can use. Plus car also shoots out to the sky usually after detaching. Anyway thanks for the reply .
          Last edited by jtarczykowski; 04-30-2017, 06:48 AM.

          Comment

          Working...
          X