Announcement

Collapse
No announcement yet.

sound cue attenuation wont replay sound.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    sound cue attenuation wont replay sound.

    perhaps there is a trick to the sound cue that im not aware of... I placed a tv in a room and set the media player to play when a character enters the trigger box... works fine when i leave the box and return.. sound start and stops. but I wanted the sound to fade with distance so I added attenuation. it worked great.. just how i wanted it to... except when i reentered the attenuation space... no sound. it only worked once. the tv was still playing and i never left the trigger space... no sound upon reentering the attenuation space.. is there a fix for this??? a checkbox somewhere? i am using version 4.15.1
    Last edited by philip robe; 03-31-2017, 06:22 PM.

    #2
    Don't stop the sound and leave it repeating with attenuation
    Inphidel / Brian - Developer of Ultraball
    http://www.ultraballgame.com

    Don't shy away from bugs in your game. Don't play it as intended. Break your game so you can fix it!

    Comment


      #3
      I'm having the same issue.

      [MENTION=274553]Inph1del[/MENTION] - I don't see any "repeat function" in the attenuation details panel. My video is set to Looping in the Media player.

      @phillip robe - did you figure it out?

      This issue started around ~4.15.

      thanks

      Comment


        #4
        sorta.... i set it to stop when exiting the sound trigger box otherwise it started kinda working but the sound and video were not in sink. now it restarts at the beginning every time... not what i really wanted... i wanted it to pause and if you reentered the room ..to continue. you know... keep the processing close to the player... perhaps later another way will appear...

        Comment


          #5
          https://youtu.be/fsjJrxHY9fQ

          Comment


            #6
            I know this is old, but I encountered the same issue recently and have a solution: in the sound cue, with nothing selected, scroll down the left-hand Details panel until you see Voice Management. This defaults to Restart. The option the OP wanted was Play when Silent, which you can select from the drop-down.

            With that set up, you can walk back through any attenuated sound as if it was always playing
            Last edited by Valkyrie_Sound; 04-20-2020, 07:25 PM.
            LinkedIn | Insta | YouTube | SoundCloud | valkyrie-sound.com | Sound Design, Composition, Production

            Comment


              #7
              Originally posted by Valkyrie_Sound View Post
              I know this is old, but I encountered the same issue recently and have a solution: in the sound cue, with nothing selected, scroll down the left-hand Details panel until you see Voice Management. This defaults to Restart. The option the OP wanted was Play when Silent, which you can select from the drop-down.

              With that set up, you can walk back through any attenuated sound as if it was always playing
              Thanks - exactly the problem I was having. Even though sound wave was set correctly the sound cue was overriding it (despite never having been modified).

              Comment


                #8
                Cool - so long as it works now!
                LinkedIn | Insta | YouTube | SoundCloud | valkyrie-sound.com | Sound Design, Composition, Production

                Comment

                Working...
                X