Announcement

Collapse
No announcement yet.

4.14 and Steamworks, does not work at all.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.14 and Steamworks, does not work at all.

    Since 3 days now, i try to implement Steamworks, without any result. (I have posted it in this area of the forums, since it originally was a Blueprint-only project, i just added code to it for steamworks implementation)


    Plguin enabled:



    Copied files to the Engine-Folder (as the Tutorials tell you to do):

    32 bit


    64 bit



    Target.cs



    Build.cs



    DefaultEngine.ini



    That is everything.

    It does not Work in "Play Standalone" or in a packaged Build (Developement).

    Does anyone have an Idea what is going on here? (i am out of ideas after 3 Days of frustrating fiddling with Stuff that in theory should be easy, but is not working anyway...)

    Thank you!

    EDIT1:
    Actually it seems to work a little bit... Steam knows that i am playing "Spacewar", but i can not get the overlay running:


    any Ideas?
    Last edited by Yaeko; 02-07-2017, 06:46 PM.

    #2
    Do you have NVIDIA Geforce Experience running? Steam overlay will not work if so. Drove me mad for days.

    EDIT: nevermind, may have been fixed, overlay works fine now for me with geforce exp.
    Last edited by vanlacke; 02-08-2017, 02:18 AM.

    Comment


      #3
      I dont have Geforce experience installed, since i do not own any nvidia Graphics cards.

      So that is not the Problem, and AMD ReLive was not running at that time.

      But it seems something is blocking the overlay...

      Are there any engine-settings that could cause that problem?

      Comment


        #4
        Make sure that you are actually allowing steam popup in Steam settings. Next, I am not sure if you should be toggling on that plugin, since you are using the Steamworks SDK, I would figure that that plugin is to enable the internal engine Steam SDK, which is an older version. So, not sure if you tried to toggle that off yet after installing the newer version of the SDK. Just throwing some things out there that popped in my head while reading this.

        **Edit, just noticed you are using the older sdk anyway...so that may be causing some conflict. You don't need to do anything extra, other than the .ini addition and activating the plugin to enable steam. And obviously having steam logged in and open.
        Last edited by VictorBurgos; 02-08-2017, 08:19 PM.
        Website/Portfolio: http://www.VictorBurgosGames.com

        Join me on stream: https://www.twitch.tv/BurgosGames for UE4 Game Dev. If you need help, just stop by and ask!

        Wishlist Neko Ghost, Jump! a 2D/3D Puzzle-Platformer : https://store.steampowered.com/app/1...ko_Ghost_Jump/

        Comment


          #5
          I don't think you need to copy files to folder anymore.. I believe a fresh install of engine and enabling the plugin work now.

          The ini stuff sure but I believe it packages the steam dependency ?
          Inphidel / Brian - Developer of Ultraball
          http://www.ultraballgame.com

          Don't shy away from bugs in your game. Don't play it as intended. Break your game so you can fix it!

          Comment

          Working...
          X