Announcement

Collapse
No announcement yet.

Errors with Packaged Build That are absent in Editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Errors with Packaged Build That are absent in Editor

    Hi,
    I'm Ibrahim. I have been working on an action-rpg title called Adrayvia for more than a year, and upon packaging the game there are some errors that occur in the packaged build that do not occur in the editor.

    The first error: There are 9 characters available for selection. Once you select a character and a map, the level is loaded and the player should be able to run around the map with or without drawing his weapon. However, only one of the characters works correctly this way. The rest of the 8 do not run or move from their spawned spot and instead just rotate in the chosen direction of movement. Upon drawing a weapon though, the characters are able to run around, but upon holstering the weapon, they are stuck in the same position and only rotate again. Testing this out in the engine's editor, all the characters work fine and can run around with no problems.

    The second error: There are UI notifications that show up on the screen when certain events occur, such as parrying successfully or attempting to launch a special technique. The widgets are made up of both text and a border. Again, within the editor, these notifications show up as designed. However, in the packaged build, only the borders show up - the actual notification text is absent. I have changed the font to the default Roboto the engine comes with as well, but the text still doesn't show up in the packaged build.

    The third error: The Health bars of the characters do not display accurate percentages of health in the packaged build, but they work fine in the editor. When a character takes damage, it should be reflected immediately in its health bar, but this isn't the case in the packaged build. It's more like the health bar only reflects the damage taken at random intervals, and even then it is not even reflecting how much damage was actually taken. For instance, if a character takes 50 damage and the health bar should drop 75% of it's max value, it only drops to about 90% or so. It's totally erratic in the packaged build, but works normally in the editor.

    These errors are quite impossible for me to debug in the editor, because they do not occur in the editor. Everything works fine in the editor. But the packaged build has these errors. I need help with these please.

    Here's a OneDrive link to a 24 sec video showing everything I've described above working fine in the editor (7.79 MB):
    https://1drv.ms/v/s!Av13Y2UmXSTQkWH-9EgBV8gCdKbZ

    Here's a OneDrive link to a 28 sec video showing all three errors described above in the packaged build (9.06 MB):
    https://1drv.ms/v/s!Av13Y2UmXSTQkWIr3qNUl-wf-Uv5

    Here's a OneDrive link to the output log of the packaging process:
    https://1drv.ms/t/s!Av13Y2UmXSTQkV2cemmKBFLaRjaN

    Please, help me figure this out.
    Thank you.

    I posted this problem on Answerhub as well. Here's the link to the Answerhub post:
    https://answers.unrealengine.com/que...t-in-edit.html
    [Released] The Art of Combat on the Marketplace
    [Released] The Targeting System
    [Portfolio] www.ibrahimakinde.com
    [Patreon] Support me as I produce Adrayvia!
    [YouTube Channel] Subscribe to my channel!
    [Discord] https://discord.gg/3CbF5Yq
    [Discord (Pm)] @Ragnar#9805

    #2
    warning: Failed to find object 'Object /Game/SnSAnimsetPro/Models/Shield/Shield.Shield'

    warning: String asset reference "FX_Meshes.UI.SM_SelectionMesh_01" is in short form, which is unsupported and -- even if valid -- resolving it will be really slow. Please consider resaving package in order to speed-up loading.

    warning: String asset reference "JW_Ice_Mountain.Mesh.SM_SnowBoulder" is in short form, which is unsupported and -- even if valid -- resolving it will be really slow. Please consider resaving package in order to speed-up loading

    Warning: String asset reference "Exo_Deco01.SM.Mesh.WoodenBarrel_Intact" is in short form, which is unsupported and -- even if valid -- resolving it will be really slow. Please consider resaving package in order to speed-up loading.

    Warning: [Compiler GradientBar_Base] Warning Compile of GradientBar_Base successful, but with 4 Warning(s) [in 39 ms] (/Game/UI_Kit/Widgets/GradientBars/GradientBar_Base.GradientBar_Base)

    Warning: Failed to load '/Game/Modern_Melee_Weapons/Kunai/SM_Kunai_01': Can't find file '/Game/Modern_Melee_Weapons/Kunai/SM_Kunai_01'

    Warning: Failed to load '/Game/BloodPack/Content/Meshes/SM_GibChunk_Skull': Can't find file '/Game/BloodPack/Content/Meshes/SM_GibChunk_Skull'

    Warning: Failed to load '/Game/BloodPack/Content/Meshes/SM_GibChunk_01': Can't find file '/Game/BloodPack/Content/Meshes/SM_GibChunk_01'

    Warning: Failed to load '/Game/External/Explosions/Mesh/shockwavetorus': Can't find file '/Game/External/Explosions/Mesh/shockwavetorus'

    Warning: Failed to load '/DungeonArchitect/DemoTheme/Meshes/FenceGlassSlab': Can't find file '/DungeonArchitect/DemoTheme/Meshes/FenceGlassSlab'

    Warning: Failed to load '/Game/SnSAnimsetPro/Models/Sword/Sword': Can't find file '/Game/SnSAnimsetPro/Models/Sword/Sword'

    Warning: GetSocketByName(None: head): No SkeletalMesh for CharacterMesh0

    Warning: GetSocketByName(None: lowerarm_l): No SkeletalMesh for CharacterMesh0
    In short: You've moved around folders and never editted your redirectors; you have a lot of messed up redirectors, fix up all your redirector files.
    This is one of the issues causing errors #1 and #2.


    Warning: Script Msg: Divide by zero
    Script call stack:
    Function /Game/_ADNeo/UI/_MP/Battle/AllBattles/VS_Mode_Bars_2P.VS_Mode_Bars_2P_C:GetHealth

    Warning: Script Msg: Divide by zero
    Script call stack:
    Function /Game/_ADNeo/UI/_MP/Battle/AllBattles/VS_Mode_Bars_2P.VS_Mode_Bars_2P_C:GetEnergy
    This is why you have error #3. Check your code on VS_Mode_Bars_2P Blueprint.
    | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

    Comment


      #3
      Thanks [MENTION=26427]B[/MENTION]runo for replying.
      I have used the 'Fix Redirectors in Folder' option to fix the redirectors, and have also taken a look at the VS_Mode_Bars_1P and VS_Mode_Bars_2P BPs. I found that the Gradient_Base widget which they use had a warning with the Ease function, and I changed that to another function. Upon repackaging, the health bars now work correctly. However, issues 1 and 2 still persist. So far I've been migrating the actual used files for the game into an empty project, configuring the empty project correctly, and then packaging to reduce cook time (the actual used files are only about 2.7 GB, but the original project folder contains about 21 GB of content, so it tries to cook the entire 21 GB). Maybe I'm not migrating some files that are needed, so I'll try packaging in the original project folder this time and see what happens. I'll let you know the results. Thanks!!
      [Released] The Art of Combat on the Marketplace
      [Released] The Targeting System
      [Portfolio] www.ibrahimakinde.com
      [Patreon] Support me as I produce Adrayvia!
      [YouTube Channel] Subscribe to my channel!
      [Discord] https://discord.gg/3CbF5Yq
      [Discord (Pm)] @Ragnar#9805

      Comment


        #4
        Okay, so I tried packaging in the original project, and the first and second errors till persist. I have fixed the redirectors, and everything in the Anim BP looks okay, so I'm not quite sure what the problem is.
        [Released] The Art of Combat on the Marketplace
        [Released] The Targeting System
        [Portfolio] www.ibrahimakinde.com
        [Patreon] Support me as I produce Adrayvia!
        [YouTube Channel] Subscribe to my channel!
        [Discord] https://discord.gg/3CbF5Yq
        [Discord (Pm)] @Ragnar#9805

        Comment


          #5
          Hi,
          So I fixed the first error. There was a variable in my character blueprint that controlled the walk speed at runtime. It didn't give any problems in the editor, so it was rather difficult to find. But anyway, that's solved.

          The second and third errors still occur.
          [Released] The Art of Combat on the Marketplace
          [Released] The Targeting System
          [Portfolio] www.ibrahimakinde.com
          [Patreon] Support me as I produce Adrayvia!
          [YouTube Channel] Subscribe to my channel!
          [Discord] https://discord.gg/3CbF5Yq
          [Discord (Pm)] @Ragnar#9805

          Comment

          Working...
          X