Announcement

Collapse
No announcement yet.

Accessed none trying to read property

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Accessed none trying to read property

    I did this thing the exact same way before and accidentally deleted it, but now i get this error: Accessed None trying to read property CallFunc_GetField_ReturnValue from function: 'ExecuteUbergraph_Login' from node: Branch in graph: EventGraph in object: Login with description: Accessed None trying to read property CallFunc_GetField_ReturnValue Click image for larger version

Name:	UserInfo.PNG
Views:	1
Size:	303.0 KB
ID:	1204666 Click image for larger version

Name:	W_Login.PNG
Views:	1
Size:	208.0 KB
ID:	1204667EDIT: Apply URL isn't either printing url or get field can't get it, but everything is set up correctly and it should
    Last edited by Draugole; 12-28-2016, 11:39 AM.

    #2
    The error tells you, that the Reference you are trying to use is "null". References don't always have values. It's like a finger pointing to the thing you want to use,
    but it can also point to,.. nothing. If that's the case, you are not allowed to access it and the error "Accessed None" returns.

    The Error happens in "OnClicked (Login)". The "GetField" seems to not return anything and calling "As String" on it, is resulting in "Accessed None".

    Before you use your References (Called "Pointers" in C++), make sure to use "IsValid" node on them. Doesn't matter which one of the both, one just needs
    the Branch as an additional node, cause it only returns true or false.

    So the field name "result" seems to be wrong?
    Open for contracted work | C++/BP (incl. Multiplayer) | Tutoring | VR

    My UE4 Blog/Page with Tutorials and more: Hit me for ALL the things!
    (Including 100+ Pages Multiplayer Network Compendium to get you started.)

    Comment


      #3
      Sorry i saw this a bit late, i started from scratch and doing it another way, i traced it down to the root of problem but everything seemed to be correct and i redid it 4 times so i just kinda gave up on that way.

      Comment


        #4
        Draugole how you did that? I'm having that error...

        Forget, It's working
        Last edited by David_CR97; 05-05-2019, 04:46 PM.
        Programmer

        Comment


          #5
          For those who may experience this error at a later date check out video #27. I go over this error in detail and give a simple example of how it is caused and what you can do to fix it.

          https://www.youtube.com/playlist?lis...1jewB5s78zQHIy

          Comment

          Working...
          X