Announcement

Collapse
No announcement yet.

Need help with project that has Wwise when updating from 4.23 to 4.24!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need help with project that has Wwise when updating from 4.23 to 4.24!!

    So as the title says... I currently have a project that was working on UE4 4.23 integrated with Wwise 2019.1.7.

    I recently upgraded the Unreal project to 4.24 and left the Wwise project untouched.

    When I opened Unreal 4.24 this window pops up and tells me that the integration with Wwise has changed and that it'll change all the Wwise events. It even deleted some of the Wwise events. Now I really don't mind setting the events again.

    Click image for larger version

Name:	TweVcJw5XR.png
Views:	65
Size:	57.8 KB
ID:	1765857

    I tested packaging the project and it completes successfully... but when testing the build it crashes whenever the game tries to execute any blueprint function related to Wwise. Now it's worth mentioning that the audio guy I'm working with set the Wwise events to play inside the character animations using Notify. Those aren't causing the crash... it's when the game tries to execute blueprints I created with Wwise functions (Post event, Set Group State,etc) that the build crashes.

    Any tips on that? Or maybe is there a specific process when trying to upgrade the Unreal Engine version when working with Wwise?

    This is a window of the Wwise Launcher.

    Click image for larger version

Name:	DhS4LN0ktN.png
Views:	36
Size:	24.9 KB
ID:	1765858

    #2
    You'll definitely want to let AudioKinetic know, you might have found an edge-case for the new way they do memory in their Unreal integration.
    Dan Reynolds
    Technical Sound Designer || Unreal Audio Engine Dev Team

    Comment

    Working...
    X