Announcement

Collapse
No announcement yet.

UE 4.25 Resonance Audio with convolution reverb Submix Send

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UE 4.25 Resonance Audio with convolution reverb Submix Send

    Hi,

    I am trying to get Resonance Audio working with the convolution reverb Submix Send working and am have some trouble. I have Resonance Audio working however the Submix Send does not work unless I change the Spatialization Method to Panning instead of Binaural. Unfortunately, changing the Spatialization Method to Panning negates the effect of Resonance Audio.

    Does anyone know if there is a way to get Resonance Audio working with convolution reverb?

    Below are screenshots of my current settings.

    Click image for larger version

Name:	project_settings.PNG
Views:	74
Size:	10.3 KB
ID:	1762821
    Click image for larger version

Name:	spatialization_method.PNG
Views:	100
Size:	14.1 KB
ID:	1762820
    Click image for larger version

Name:	submix_spatialization.PNG
Views:	75
Size:	59.1 KB
ID:	1762822

    #2
    Out of curiosity, does the manual Submix Send on your Sound Source still work?
    Dan Reynolds
    Technical Sound Designer || Unreal Audio Engine Dev Team

    Comment


      #3
      Hi Dan,

      Thank you for the response. The Submix Send Method values Linear, Manual and Custom Curve all do not work when the Spatialization Method is set to Binaural. When Spatialization Method is set to Panning then they all work.

      The value Manual for Submix Send Method does work if I uncheck Enable Spatialization.

      Comment


        #4
        Sorry, I meant directly from the SoundWave or SoundCue.

        Unfortunately, I was not able to reproduce your problem--for me Resonance works with the Submix sends.

        Can you try setting the Min Send Value to something other than 0?

        What are your Resonance settings, out of curiosity?
        Dan Reynolds
        Technical Sound Designer || Unreal Audio Engine Dev Team

        Comment


          #5
          I tested the Attenuation Submix Send settings on the Sound Cue and got the same results as using the Sound Attenuation settings. However if I use the Effects > Submix > Submix Sends in the Sound Cue then it works with Resonance. Since it works in this location, having it work through the Sound Attenuation settings is not critical. It would make things a bit easier though.
          Click image for larger version

Name:	Effects_Submix.jpg
Views:	32
Size:	41.3 KB
ID:	1765495

          In the Sound Attenuation settings, changing the Min Send Value to something other than 0 did not change the results.

          Below are screenshots of my Resonance settings. I also tried controlling the distance through the Resonance Audio Spatialization Settings instead of the Unreal Attenuation Distance settings and the results did not change.
          Click image for larger version

Name:	Resonance_03.jpg
Views:	24
Size:	22.9 KB
ID:	1765496
          Click image for larger version

Name:	Resonance_01.jpg
Views:	24
Size:	33.8 KB
ID:	1765497
          Click image for larger version

Name:	Resonance_02.jpg
Views:	24
Size:	25.3 KB
ID:	1765498

          I also tested with a new project and the results were the same for me. So there must be some setting that is incorrect somewhere.

          Comment

          Working...
          X