Announcement

Collapse
No announcement yet.

SampleRate and NumChannels have value of 0 in Time Synth when you set your own Quantization Settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SampleRate and NumChannels have value of 0 in Time Synth when you set your own Quantization Settings

    Anyone else having this issue? When setting my own quantization settings, Sample Rate and Num Channels gets set to 0 (using default settings works just fine, with SampleRate at 48k and NumChannels at 2). Since the value is 0, this causes check(NumFramesPerBar != 0) to get hit. Not sure why adjusting quantization settings would break like this. With both those values being 0 it's almost as if some stuff isn't getting initialized.

    Am I suppose to be setting the quantization settings in some other fashion? I didn't see the quantization settings BP node used anywhere in the example project, so maybe I am just using it wrong?

    Thanks,
    Blake
    Last edited by Blakeanator; 01-08-2020, 09:48 PM.

    #2
    I think there is a bug in the initialization, try Activating the Time Synth Component before setting Quantization Settings.
    Dan Reynolds
    Technical Sound Designer || Unreal Audio Engine Dev Team

    Comment


      #3
      Originally posted by dan.reynolds View Post
      I think there is a bug in the initialization, try Activating the Time Synth Component before setting Quantization Settings.
      Calling Activate() on the TimeSynth Component before adjusting quantization settings did indeed fix the crash. Thanks for providing a solution Didn't realize I needed to call Activate() manually.

      Blake

      Comment


        #4
        We are hoping to address some of these bugs soon.
        Dan Reynolds
        Technical Sound Designer || Unreal Audio Engine Dev Team

        Comment

        Working...
        X