Announcement

Collapse
No announcement yet.

Audio Volume Effect Not Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Audio Volume Effect Not Working

    Hey guys,

    My apologies if I'm missing something very simple, but I cannot for the life of me figure out how to make an audio volume affect sounds, either from a cue in the world or the firing sound of the template first person character. I have created an audio volume that encompasses the entire first person level, and added a reverb effect (increasing decay time as well). It says it's enabled, and I've followed multiple tutorials as closely as I can but to no avail.

    I am running Unreal 4.23.1 on Windows 10. Any help would be greatly appreciated.

    Cheers,
    Anemony.

    #2
    Same here, not matter what I do I can't get my audio volumes to do anything.

    Not with exsisting projects or even fresh new templates !

    Comment


      #3
      Yep, same here... 4.23.1 on Windows10

      Comment


        #4
        Sound Class -> Apply Ambient Volumes (true)

        Create a sound class. Tick "Apply Ambient Volumes". For each sound that is suppose to work with audio volumes change out the sound class.

        Comment


          #5
          Took me too long to find this
          You need to turn on override attenuation to have the AudioVolume effect the sound. This was not mentioned in the book I'm learning from.
          See attachment.
          Attached Files

          Comment


            #6
            If you're playing a 2D sound that you want sent to Reverb, you will need to express how it gets sent in its SoundClass data.
            Dan Reynolds
            Technical Sound Designer || Unreal Audio Engine Dev Team

            Comment


              #7
              Hi, There's a weird thing with the Audio Volume, when it's not set to enabled, it still has the reverb effect activated. Is it a bug?
              Another thing, I can't disable the reverb effect in blueprint, I have to completely disable the Audio Volume. Bug as well?
              The whole Reverb, audio volume framework seem to be a bit broken isn't it?

              Comment


                #8
                Same here.
                I made sure the SoundCue I am playing is using a SoundClass with the Apply Ambient Volumes set to true.
                Tried to have a sound in the persistant level with "Override attenuation cheked"
                Tried to spawn a sound at player's location inside of an Audio Volume.
                It doesn't effect the sound at all.
                What am I missing?

                Comment


                  #9
                  same problem. That seems to be a bug man. ufff.. was so excited to hear about the new update .. but simple things like this got really complicated.. and at the end .. a simple volume boost just doesn't seem to work. We need help or a clear direction. Thanks a lot!

                  Comment


                    #10
                    Been bashing my head around this for a couple of hours, and finally got it to work

                    looks like the default sound class for all imported sounds is "master" i found it on engine>engine sounds, so a ticked the "apply ambient volumes" on it

                    i also didnt know that i could select the sound class by opening the sound asset double clicking it

                    when i did it, it started working, the one thing i dont see on this tread is the size of the audio volume, my camera is far far away, 20.000 units, so when i make the audio volume huge to overlap it the volume works

                    thanks a lot for the info above



                    Comment


                      #11
                      one sec man.. where did you tick to apply the ambient volume?
                      could you give us a break down or some visual screenshots.... still not working on my end..

                      thanks a lot man.. cheers

                      Comment

                      Working...
                      X