Announcement

Collapse
No announcement yet.

Ambisonics not working in UE4.22 ???

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Ambisonics not working in UE4.22 ???

    It seems that Ambisonics is broken in 4.22. Can anyone confirm this and / or provide details of an expected fix?

    In 4.21.2 it appears to be working fine

    In 4.22.2 Ambisonics does not work and I get a speaker-shattering blast of digital noise when trying to preview an Ambisonics file in the Content Browser

    In 4.22.3 Ambisonics doesn't work and I just get a small audio glitch when trying to preview an Ambisonics file in the Content Browser.

    I am trying to play Ambisonics with the Google Resonance plug in enabled.

    My suspicion is that the new Epic Audio Spatialisation plug in (introduced in 4.22) is not playing nice alongside Google Resonance.

    Any info greatly appreciated.

    #2
    Originally posted by aljacksonjr View Post
    It seems that Ambisonics is broken in 4.22. Can anyone confirm this and / or provide details of an expected fix?

    In 4.21.2 it appears to be working fine

    In 4.22.2 Ambisonics does not work and I get a speaker-shattering blast of digital noise when trying to preview an Ambisonics file in the Content Browser

    In 4.22.3 Ambisonics doesn't work and I just get usps tracking a small audio glitch when trying to preview an Ambisonics file in the Content Browser.

    I am trying to play Ambisonics with the Google Resonance plug in enabled.

    My suspicion is that the new Epic Audio Spatialisation plug in (introduced in 4.22) is not playing nice alongside Google Resonance.

    Any info greatly appreciated.
    I am also facing the same on 4.22.x. Is there any fix? Help is highly appreciated.

    Thanks in advance.
    Regards,
    Brian
    Last edited by BrianL1; 07-14-2019, 01:29 PM.
    gimp freejobalert notepad++

    Comment


      #3
      I can confim. I updated the Google Resonance Plugin but it still destroys my headphones with extreme buzzing and crackling sounds as soon as i enable ambisonics. I will quickly test android too.

      Comment


        #4
        I would recommend, if suitable for your projects, to use the UE4 plugin included in the Rendering SDK of Facebook's 360 Spatial Workstation. It plays up to 3rd order ambisonics, with HMD tracking and amazing sounding localization over headphones. I was also able to modify it to finish their incomplete Android support and also to have the audio routed through Unreal's audio mixer instead of directly to the audio hardware. I've tested it with both 4.22 and 4.23 and works great.

        https://facebook360.fb.com/downloads...ng-sdk-v1-6-0/

        Comment


          #5
          Originally posted by jinzay View Post
          I can confim. I updated the Google Resonance Plugin but it still destroys my headphones with extreme buzzing and crackling sounds as soon as i enable ambisonics. I will quickly test android too.
          Same issue has been described here: https://essaytyper.pro/

          Comment


            #6
            I was able to confirm that Google Resonance Ambisonics is working on 4.23 last week. You might want to check out Preview 6 and see if that's working for you.
            Dan Reynolds
            Technical Sound Designer || Unreal Audio Engine Dev Team

            Comment


              #7
              Originally posted by virtualHC View Post
              I would recommend, if suitable for your projects, to use the UE4 plugin included in the Rendering SDK of Facebook's 360 Spatial Workstation. It plays up to 3rd order ambisonics, with HMD tracking and amazing sounding localization over headphones. I was also able to modify it to finish their incomplete Android support and also to have the audio routed through Unreal's audio mixer instead of directly to the audio hardware. I've tested it with both 4.22 and 4.23 and works great.

              https://facebook360.fb.com/downloads...ng-sdk-v1-6-0/
              Can't install the facebook plugin, the version you mention or the latest version. In both 4.22 and 4.23 (after copying the folder) I get this message:
              Plugin 'Audio360' failed to load because module 'Audio360' could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.

              I am a UE4 newbie so maybe I'm doing smth else wrong... Some help appreciated.

              Comment

              Working...
              X