Announcement

Collapse
No announcement yet.

Audio Record from mic in Unreal Package

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Audio Record from mic in Unreal Package

    Hi everyone!

    I just to know the best way from which i can record my voice through mic and can save it to the unreal package while playing the game.

    Game Designer

    #2
    Hi ankit00714,

    There's a new feature released in 4.20 that allows you to record a Submix to a SoundWave asset. Along with the Audio Capture component which lets you route incoming microphone input to a Submix of your choosing, you should be able to generate a SoundWave asset.

    However, to save it between gameplay sessions, I believe you'll need to serialize it with the rest of your Game Save data. I definitely haven't tried to do this yet; not sure anyone has.
    Dan Reynolds
    Technical Sound Designer || Unreal Audio Engine Dev Team

    Comment


      #3
      Hi dan.reynolds,

      I've tried what you suggest, using the Audio Capture component and the new blueprint node to save a submix into a file.

      However, the audio that the microphone is recording is also reproduced on my speakers. Any idea how can I turn this off?

      Thanks

      Comment


        #4
        Hey, had the same problem with the recording being reproduced to the speakers. Hook me up if there is a real fix!

        Until now what I did, was adding a master submix effect with the gain set to -90db (to mute all sound) and released the effect when finishing the recording. Not that beautiful, but better than hearing my own voice..

        Comment


          #5
          Hi Lolukok
          A bit of a long shot , but i'm trying to do the same thing is this how or am i missing something
          After doing this my game audio is muted like you said but so is my recording
          Attached Files

          Comment


            #6
            Hi all,

            Apologies for jumping on an old thread, but really hoping someone can help.

            I'm seeing the same issue mentioned above and was wondering if it's possible to mute the audio through the speakers whilst recording sound through a mic. I'm currently using a HTC Vive headset to successfully record my voice in-game (and save it out as a .wav file) but while I'm recording, everything I say is output through the headset speakers (which makes for a very distracting echo!)

            Lolukok as you suggest, I've tried effectively muting the output sound, but that also seems to mute the recording itself (presumably, my game needs to hear the audio output in order to record it) were you still able to hear your recordings after muting your sound?

            dan.reynolds if you have any advice on this at all, I'd really appreciate it.

            (Just FYI, I'm using UE version: 4.23.1)


            Thanks,

            Az
            Last edited by Aznazeepe; 04-08-2020, 08:01 PM.

            Comment


              #7
              You will need to have a Submix Effect that kills the gain of that submix and then have the recording submix upstream from it.
              Dan Reynolds
              Technical Sound Designer || Unreal Audio Engine Dev Team

              Comment


                #8
                Hey I got it working! I could not get the dynamicsProcessor submix effect to work as a total limiter - there was always some audio coming through with all settings i tried. In the end i used one low pass and one high pass filter, each set to not let anything through, to get silence!
                The recording and visualization of the submix still works.

                edit: we don't even need effects to silence - we can set the submix output to 0 vol as in the picture below. Seems to work.

                Click image for larger version  Name:	jpegSubmixRecordSilently.jpg Views:	166 Size:	385.5 KB ID:	1743223
                Last edited by ArthurBarthur; 05-06-2020, 02:50 AM.
                Try my procedural music tools: Arthurs Audio BPs

                Comment


                  #9
                  Originally posted by ArthurBarthur View Post
                  Hey I got it working! I could not get the dynamicsProcessor submix effect to work as a total limiter - there was always some audio coming through with all settings i tried. In the end i used one low pass and one high pass filter, each set to not let anything through, to get silence!
                  The recording and visualization of the submix still works.

                  edit: we don't even need effects to silence - we can set the submix output to 0 vol as in the picture below. Seems to work.

                  Click image for larger version Name:	jpegSubmixRecordSilently.jpg Views:	166 Size:	385.5 KB ID:	1743223
                  You need to go into more detail on how you set up the submix. My submix in 4.22 looks nothing like yours at all.

                  Comment


                    #10
                    Originally posted by crossmr View Post

                    You need to go into more detail on how you set up the submix. My submix in 4.22 looks nothing like yours at all.
                    We make a few submix assets, then open one of the submix assets, and add the rest inside there, and connect them as well! Can choose settings for each. There is an even newer and better in-editor example giving the same results in the latest Arthurs Audio Blueprints!

                    Edit: also you are on 4.22? Then I don't think I can help you. Stuff changes so fast these days!!!! I would rrrrrrrrrreally try to get on 4.25...it's good and solid!
                    Last edited by ArthurBarthur; 06-29-2020, 10:45 AM.
                    Try my procedural music tools: Arthurs Audio BPs

                    Comment

                    Working...
                    X