Announcement

Collapse
No announcement yet.

How to setup ambisonics playback in 4.19?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to setup ambisonics playback in 4.19?

    Hello,

    I'm trying to test the new ambisonic playback functionality in 4.19 but so far I haven't been able to get it to work. So far this is what I've tried:

    1. With the new audio engine enabled, I created a new project, enabled the Oculus Audio plugin (restarted) and Imported a 4 channel b-format audio file (had to convert it to 16 bits first since 24 is not supported).
    2. In the sound wave asset settings, I checked "isAmbisonics"
    3. Under Sound Submix I created a new submix and in it I set the "Ambisonics Plugin Settings" with a new Oculus Ambisonics Settings and set the channel format to Ambisonics.
    4. Dropper the file in the scene and played

    The result is that the audio file plays but it's not decoding. Removing the Sound Submix asset doesn't make a difference. What am I missing? I also tried adding an Attenuation asset but I also couldn't hear a difference.

    Thank you.
    Last edited by virtualHC; 02-11-2018, 06:27 PM.

  • #2
    You need to set Oculus as the spatialization plugin to use in the project settings for the platform. It's a little confusing since we support different plugins for different audio engine effects. e.g. you could use Oculus on PC, Resonance on Android, and Steam Audio for Mac or something with the same project, so there needs to be a way to specify that.

    This is an issue for lots of people so we're considering ways to maybe do an auto-discovery and use the project settings as an override or something.

    Comment


    • #3
      Thank you very much Minus_Kelvin. Yes, I knew there had to be a plugin selection setting somewhere but I was expecting to find it under Audio settings. It does make sense that it is be a platform specific setting, though.

      I selected Oculus Audio under Platforms/Windows/Spatialization Plugin but still I can't hear the ambisonic decoding and it doesn't seem to make a difference what I choose there. Should this setting work for PIE too? I'm running UE4 on Windows 10.

      Comment


      • #4
        Hi VirtualHC!

        In order to use Ambisonics with Oculus, you'll need to designate a Submix and how you want to handle the ambisonics file in the mix.

        So create a Sound Submix for your Ambisonics file to output to and then you'll want to create a Ambisonics Setting Asset which you will apply to that submix. Both of these are assets, so let me know if you need help creating them or assigning things.
        Dan Reynolds
        Technical Sound Designer || Unreal Audio Engine Dev Team

        Comment


        • #5
          Originally posted by dan.reynolds View Post
          Hi VirtualHC!

          In order to use Ambisonics with Oculus, you'll need to designate a Submix and how you want to handle the ambisonics file in the mix.

          So create a Sound Submix for your Ambisonics file to output to and then you'll want to create a Ambisonics Setting Asset which you will apply to that submix. Both of these are assets, so let me know if you need help creating them or assigning things.
          Hi Dan,

          Thank you for your reply. After setting things up again I seem to now get properly decoded ambisonics. The only issue I'm facing is that camera rotation doesn't rotate the soundfield and acoustic orientation remains fixed. Non ambisonic sounds are being localized properly (and sounding great with Oculus' near-field effect!).
          Last edited by virtualHC; 02-12-2018, 11:21 PM.

          Comment


          • #6
            For Oculus Audio, would it be ovrAudio_SetAmbisonicOrientation (in OVR_Audio.h) that needs to be called with the camera rotation? A quick search throughout the 4.19 source seems to show that this is not being called from anywhere.

            Comment

            Working...
            X